dev-util/idea-ultimate: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Sun, 13 Oct 2019 12:41:07 +0000 (14:41 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 13 Oct 2019 12:41:07 +0000 (14:41 +0200)
Closes: https://bugs.gentoo.org/694264
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/idea-ultimate/Manifest [deleted file]
dev-util/idea-ultimate/idea-ultimate-2017.3.1.173.3942.27.ebuild [deleted file]
dev-util/idea-ultimate/metadata.xml [deleted file]
profiles/package.mask

diff --git a/dev-util/idea-ultimate/Manifest b/dev-util/idea-ultimate/Manifest
deleted file mode 100644 (file)
index 57d4e42..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST ideaIU-173.3942.27-no-jdk.tar.gz 562044023 BLAKE2B 57da196682db817b175158b9c9913502490c2a692153e5e5b8a4449958c5613469a0060f1260095e9fb70ca54b5adaf59494cd9c0f6b0cb0b9f7c25cc4571335 SHA512 9cc7e687bef5d213f37e2e24aa2464e0d3dc9a40cb683d1d8fd1438efc6ca988134509a96f558ec87960e950336e062d5161ef6cb491f9c1c572ba077dd0a990
-DIST ideaIU-173.3942.27.tar.gz 635548505 BLAKE2B e123d731b3516dee3342310b3204dce2247430e81240e4dc729b23146887fef552001bee9aad7528d46c0717654507f16b505f76baf8407609cb9cca7aa9d773 SHA512 1f3586bc2082feec5b986298334445c7b91318f6d5f3d71fe6bfbb1546a63bb33e2bc978ef5fc4438e13d2a3d1dd5abc96fdd4ea5659f64563afbdd3410df8b4
diff --git a/dev-util/idea-ultimate/idea-ultimate-2017.3.1.173.3942.27.ebuild b/dev-util/idea-ultimate/idea-ultimate-2017.3.1.173.3942.27.ebuild
deleted file mode 100644 (file)
index abad054..0000000
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils versionator
-
-SLOT="0"
-PV_STRING="$(get_version_component_range 4-6)"
-MY_PV="$(get_version_component_range 1-3)"
-MY_PN="idea"
-
-# distinguish settings for official stable releases and EAP-version releases
-if [[ "$(get_version_component_range 7)x" = "prex" ]]
-then
-       # upstream EAP
-       KEYWORDS=""
-       SRC_URI="
-       !custom-jdk? ( https://download-cf.jetbrains.com/idea/${MY_PN}IU-${PV_STRING}-no-jdk.tar.gz )
-       custom-jdk? ( https://download-cf.jetbrains.com/idea/${MY_PN}IU-${PV_STRING}.tar.gz )
-       "
-else
-       # upstream stable
-       KEYWORDS="~amd64 ~x86"
-       SRC_URI="
-       !custom-jdk? ( https://download-cf.jetbrains.com/idea/${MY_PN}IU-${MY_PV}-no-jdk.tar.gz -> ${MY_PN}IU-${PV_STRING}-no-jdk.tar.gz )
-       custom-jdk? ( https://download-cf.jetbrains.com/idea/${MY_PN}IU-${MY_PV}.tar.gz -> ${MY_PN}IU-${PV_STRING}.tar.gz )
-       "
-fi
-
-DESCRIPTION="A complete toolset for web, mobile and enterprise development"
-HOMEPAGE="https://www.jetbrains.com/idea"
-
-LICENSE="IDEA
-       || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
-IUSE="-custom-jdk"
-RESTRICT="bindist mirror"
-
-DEPEND="!dev-util/${PN}:14
-       !dev-util/${PN}:15"
-RDEPEND="${DEPEND}
-       >=virtual/jdk-1.7:*"
-S="${WORKDIR}/${MY_PN}-IU-${PV_STRING}"
-
-QA_PREBUILT="opt/${PN}-${MY_PV}/*"
-
-src_prepare() {
-       eapply_user
-       if ! use amd64; then
-               rm -r plugins/tfsIntegration/lib/native/linux/x86_64 || die
-       fi
-       if ! use arm; then
-               rm bin/fsnotifier-arm || die
-               rm -r plugins/tfsIntegration/lib/native/linux/arm || die
-       fi
-       if ! use ppc; then
-               rm -r plugins/tfsIntegration/lib/native/linux/ppc || die
-       fi
-       if ! use x86; then
-               rm -r plugins/tfsIntegration/lib/native/linux/x86 || die
-       fi
-       if ! use custom-jdk; then
-               if [[ -d jre ]]; then
-                       rm -r jre || die
-               fi
-       fi
-       rm -r plugins/tfsIntegration/lib/native/solaris || die
-       rm -r plugins/tfsIntegration/lib/native/hpux || die
-}
-
-src_install() {
-       local dir="/opt/${PN}-${MY_PV}"
-
-       insinto "${dir}"
-       doins -r *
-       fperms 755 "${dir}"/bin/{idea.sh,fsnotifier{,64}}
-
-       if use custom-jdk; then
-               if [[ -d jre ]]; then
-               fperms 755 "${dir}"/jre/jre/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
-               fi
-       fi
-
-       make_wrapper "${PN}" "${dir}/bin/${MY_PN}.sh"
-       newicon "bin/${MY_PN}.png" "${PN}.png"
-       make_desktop_entry "${PN}" "IntelliJ Idea Ultimate" "${PN}" "Development;IDE;"
-
-       # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
-       mkdir -p "${D}/etc/sysctl.d/" || die
-       echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
-}
diff --git a/dev-util/idea-ultimate/metadata.xml b/dev-util/idea-ultimate/metadata.xml
deleted file mode 100644 (file)
index a6968e8..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
-       <email>alicef@gentoo.org</email>
-       <name>Ferrazzi Alice</name>
-</maintainer>          
-<longdescription lang="en">
-       Excel at enterprise, mobile and web development with Java, Scala and Groovy, with all the latest modern technologies and frameworks available out of the box.
-</longdescription>
-<use>
-       <flag name="custom-jdk">Install and use IntelliJ's custom JRE.</flag>
-</use>
-</pkgmetadata>
index 3ffc38348ccde2f208650c461e3ebe6942bc7bd4..9854b324dfbf3346a663a2641333d738e0a957ec 100644 (file)
@@ -532,12 +532,6 @@ dev-python/txsocksx
 dev-python/wsgilog
 dev-python/xmpppy
 
-# Michał Górny <mgorny@gentoo.org> (2019-09-13)
-# Last bumped in 2017.  Newer version fails to fetch.  Pending bump.
-# Unresolved license issues.
-# Removal in 30 days.  Bug #694264.
-dev-util/idea-ultimate
-
 # Lars Wendler <polynomial-c@gentoo.org> (2019-09-04)
 # Unofficial build. Superseded by official 2.49.5 release.
 # Masked for removal.