app-admin/puppet-agent: 6.12.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 16 Jan 2020 17:21:32 +0000 (11:21 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 16 Jan 2020 17:21:32 +0000 (11:21 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-admin/puppet-agent/Manifest
app-admin/puppet-agent/puppet-agent-6.12.0.ebuild [new file with mode: 0644]

index 71b725f3c0312f0e9580db7ec42bf4ffeb2f687b..a4d5d74bb125ef9763a43d25a844010136a3007e 100644 (file)
@@ -1,2 +1,4 @@
 DIST puppet-agent_6.11.1-1stretch_amd64.deb 19948710 BLAKE2B 256588922cfacb1d8146cd1142c43d893a55dfb67d7f70ca311df6178e7f9a82a0702d8306e0575d3f817e53c091fd3010027512cb4ce95956bdfa968372cc21 SHA512 90c39d55a8761185f82c9ac106d696ae48a170679e6043b6b3db32254e918b1b9c1b32c4e9721e5751189f84f002415f21a627daa22738a8c1ae3cb5df514eb3
 DIST puppet-agent_6.11.1-1stretch_i386.deb 20327410 BLAKE2B c2a105139df97395f54bb54d7ac971d914dcd3b69614dca55fe443d9fe5360118b899610a6d2d85b96b8b45715864df608d0783a3aabad3a2ae5555a0d510a2e SHA512 5d1173534beb53325d3c7c2fd500a7bd82a389fa8cbc9e867f6acbb6c2647190339d3b096e8a054aff268f27c5bd7de65c371a474b9c8263e8fa36bab75452bd
+DIST puppet-agent_6.12.0-1stretch_amd64.deb 20011636 BLAKE2B f83b795f07771d70220cac71d9b6d8ac7270a20fd5b78471ccef1c8ff802af3c035477f7741e775b10bc609d016a6e9fb79b199987e34b7d4f9a427c4adcd39f SHA512 dda8fa45b961d4a775da7eb128887eee3ceb9887d1062bc2fc748f6055811600162dfb2c4fbf87e401ad404813d2de0cc58ce7aade0aa23af637bb3707896126
+DIST puppet-agent_6.12.0-1stretch_i386.deb 20369446 BLAKE2B f01e39a1b307657569084e2ade1d41f17eefaa2048035f635437159e4373386c6413fa71756594d4a8748ffa0bbbdc2c54c72e696a390380bc9c57721ef010b3 SHA512 fc58e5ea22bd3dd36278db37e46d20809e284db5645ab680fb2c461ee9e4f9e635550f924278905ec13a8f9a71fbf604959e8522e4c0da52709c42f309a04921
diff --git a/app-admin/puppet-agent/puppet-agent-6.12.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.12.0.ebuild
new file mode 100644 (file)
index 0000000..36e4354
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+       amd64? ( ${SRC_BASE}_amd64.deb )
+       x86?   ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/puppet
+       !dev-ruby/hiera
+       !dev-ruby/facter
+       !app-emulation/virt-what"
+
+DEPEND="
+       ${CDEPEND}
+       app-admin/augeas"
+RDEPEND="${CDEPEND}
+       app-portage/eix
+       sys-apps/dmidecode
+       sys-libs/glibc
+       sys-libs/readline:0/7
+       sys-libs/ncurses:0[tinfo]
+       selinux? (
+               sys-libs/libselinux[ruby]
+               sec-policy/selinux-puppet
+       )
+       puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+       enewgroup puppet
+       enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+       # conf.d
+       doconfd etc/default/puppet
+       doconfd etc/default/pxp-agent
+       # logrotate.d
+       insinto /etc/logrotate.d
+       doins etc/logrotate.d/pxp-agent
+       # puppet itself
+       insinto /etc/puppetlabs
+       doins -r etc/puppetlabs/*
+       # logdir for systemd
+       dodir var/log/puppetlabs/puppet/
+       fperms 0750 var/log/puppetlabs/puppet/
+       # the rest
+       insinto /opt
+       dodir opt/puppetlabs/puppet/cache
+       doins -r opt/*
+       fperms 0750 /opt/puppetlabs/puppet/cache
+       # init
+       newinitd "${FILESDIR}/puppet.initd" puppet
+       systemd_dounit lib/systemd/system/puppet.service
+       systemd_dounit lib/systemd/system/pxp-agent.service
+       systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+       # symlinks
+       chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+       chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+       dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+       dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+       dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+       dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+}