sys-apps/iproute2: QAfix emptydir /var/lib/arpd
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 17 Apr 2020 19:39:33 +0000 (12:39 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 17 Apr 2020 19:39:54 +0000 (12:39 -0700)
Closes: https://bugs.gentoo.org/647032
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
sys-apps/iproute2/iproute2-5.6.0.ebuild

index 9e2e1f7f4e540927af55848aa4b5298b8da7b380..7670dd448c2efcf4d99ec9afc02d49d935880771 100644 (file)
@@ -158,5 +158,7 @@ src_install() {
                # bug 47482, arpd doesn't need to be in /sbin
                dodir /usr/bin
                mv "${ED}"/sbin/arpd "${ED}"/usr/bin/ || die
+       elif [[ -d "${ED}"/var/lib/arpd ]]; then
+               rmdir "${ED}"/var/lib/arpd || die
        fi
 }