dev-libs/libpqxx: Bump to 5.0.1
authorAaron W. Swenson <titanofold@gentoo.org>
Mon, 10 Jul 2017 16:38:00 +0000 (12:38 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Mon, 10 Jul 2017 16:38:56 +0000 (12:38 -0400)
Version bump fixes bug 604906.
Bump EAPI to 6.
New dependencies for building documentation.
Use dodoc instead of dohtml.
Add slot dependency to dev-db/postgresql.

Bugs: 604906

Package-Manager: Portage-2.3.6, Repoman-2.3.1

dev-libs/libpqxx/Manifest
dev-libs/libpqxx/libpqxx-5.0.1.ebuild [new file with mode: 0644]

index d4644e6b6a24eeb5b9304dea4fc7ac279a178f2e..78db94de1d953e6bdc811c48dfb1df7010fb8afb 100644 (file)
@@ -1 +1,2 @@
 DIST libpqxx-4.0.1.tar.gz 1582532 SHA256 097ceda2797761ce517faa5bee186c883df1c407cb2aada613a16773afeedc38 SHA512 00204985097ef8bb0a3376d6ba541dbb471d7c52d7135f6244a9f4acbf6c8e5254d6f813e4411421e49bb56f4a520fc6ac67e300141d724396ce0ac11bd3a95e WHIRLPOOL d377863f9200e7ed235f8a2cf132b554efa4223d5f542eea23d743ffe391a13d44da767ee2f70146558e5b393ba334656c09007241c1aadde750c00c16e25c12
+DIST libpqxx-5.0.1.tar.gz 743560 SHA256 21ba7167aeeb76142c0e865127514b4834cefde45eaab2d5eb79099188e21a06 SHA512 a097a419301d45e8078af08eb4667b7ae06c91d8bb62d57d26e0f6df138eeea350d4ba672a96271f724b3de86f3dd1d57da81aee093835c4b08b2084e98720ef WHIRLPOOL ca447f769f01a876edae5fd05c9b42fb6c33c5684ba61e07b1055586f332310290d85f2dfea9ba4d537100d427b342afd3f75ba948def9b70dabc68ac926d28a
diff --git a/dev-libs/libpqxx/libpqxx-5.0.1.ebuild b/dev-libs/libpqxx/libpqxx-5.0.1.ebuild
new file mode 100644 (file)
index 0000000..b7801bb
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Standard front-end for writing C++ programs that use PostgreSQL"
+SRC_URI="https://github.com/jtv/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://pqxx.org/development/libpqxx/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND="dev-db/postgresql:="
+DEPEND="${PYTHON_DEPS}
+               ${RDEPEND}
+               doc? (
+                        app-doc/doxygen
+                        app-text/xmlto
+               )
+"
+
+src_prepare() {
+       sed -e 's/python/python2/' \
+               -i tools/{splitconfig,template2mak.py} \
+               || die "Couldn't fix Python shebangs"
+
+       eapply_user
+}
+
+src_configure() {
+       local myconf
+       use static-libs && myconf="--enable-static" || myconf="--enable-shared"
+
+       econf ${myconf} $(use_enable doc documentation)
+}
+
+src_install () {
+       emake DESTDIR="${D}" install
+
+       dodoc AUTHORS ChangeLog NEWS README*
+       use doc && dodoc -r doc/html
+}
+
+src_test() {
+       einfo "The tests need a running PostgreSQL server and an existing database."
+       einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
+       einfo "set PGPORT and PGHOST. Define them at the command line or in:"
+       einfo "    ${EROOT%/}/etc/libpqxx_test_env"
+
+       if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
+               if [[ -f ${EROOT%/}/etc/libpqxx_test_env ]] ; then
+                       source "${EROOT%/}/etc/libpqxx_test_env"
+                       [[ -n $PGDATABASE ]] && export PGDATABASE
+                       [[ -n $PGHOST ]] && export PGHOST
+                       [[ -n $PGPORT ]] && export PGPORT
+                       [[ -n $PGUSER ]] && export PGUSER
+               fi
+       fi
+
+       if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
+               local server_version
+               server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
+               if [[ $? = 0 ]] ; then
+                       # Currently works with highest server version in tree
+                       #server_version=$(echo ${server_version} | cut -d " " -f 2 | cut -d "." -f -2 | tr -d .)
+                       #if [[ $server_version < 92 ]] ; then
+                               cd "${S}/test"
+                               emake check
+                       #else
+                       #       eerror "Server version must be 8.4.x or below."
+                       #       die "Server version isn't 8.4.x or below"
+                       #fi
+               else
+                       eerror "Is the server running?"
+                       eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
+                       eerror "    Role: ${PGUSER}"
+                       eerror "    Database: ${PGDATABASE}"
+                       die "Couldn't connect to server."
+               fi
+       else
+               eerror "PGDATABASE and PGUSER must be set to perform tests."
+               eerror "Skipping tests."
+       fi
+}