dev-java/javatoolkit: EAPI 6 and version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 7 Aug 2017 19:18:38 +0000 (21:18 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 7 Aug 2017 19:18:54 +0000 (21:18 +0200)
javatoolkit 0.4.0 is Python 3 compatible, \o/!

Package-Manager: Portage-2.3.6, Repoman-2.3.1

dev-java/javatoolkit/Manifest
dev-java/javatoolkit/javatoolkit-0.4.0.ebuild [new file with mode: 0644]

index 071901b215e3fee8a0a04e441cc525b79e455a55..e051e8eef6c5c226610f9251527b226b31343efc 100644 (file)
@@ -1 +1,2 @@
 DIST javatoolkit-0.3.0.tar.bz2 16823 SHA256 47bf8aad2ec58b2d850e8cbe57fe2707859d800b215b24387c7652a50353677c SHA512 e7bbe04e39ab277d0aab89f0eea963c4b0341a336660dab08bfad0510ad1b2b49ce7410a2363bcf9ebad5f8757ee254ddc27af642b4bfb374db52d82cf02c3b1 WHIRLPOOL a9b1034939a0e22c49620bb29d3652e8f5e6a8e71645556fe00463aabc0c1ff2ac2b666f59fd0ceea8ea5dc18579d90cc11a07ba341028831e3b8dd1e8a0e9ce
+DIST javatoolkit-0.4.0.tar.bz2 32156 SHA256 607d383024f2fcb74472f24d1c5bb2bd14929b38738613574737356ed6546c9a SHA512 1b5b596546342312eb841ca59f212ca2a09b2c872c4b6d29d984bb8017eb36b72e5c03ec2ed1e01e2900284495da9809e607c8156a5f26d40f94752847dba7f4 WHIRLPOOL b95ca41e0fb02ad7d078681d1232ce7dfdfec9748c5c71c4cdd273fdcb540a14c053016e2adab32074d5c8d510b336698b73757e2487d3596748cc7802268815
diff --git a/dev-java/javatoolkit/javatoolkit-0.4.0.ebuild b/dev-java/javatoolkit/javatoolkit-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..2548a6e
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multilib prefix
+
+DESCRIPTION="Collection of Gentoo-specific tools for Java"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_prepare_all() {
+       hprefixify src/py/buildparser src/py/findclass setup.py
+
+       distutils-r1_python_prepare_all
+}
+
+python_install() {
+       distutils-r1_python_install \
+               --install-scripts="${EPREFIX}"/usr/$(get_libdir)/${PN}/bin
+}