app-editors/gummi: Bump to 0.7.999 (GTK+3 pre-release)
authorChristian Tietz <christian.tietz@mailbox.org>
Sat, 26 Oct 2019 13:50:27 +0000 (15:50 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 29 Oct 2019 06:09:38 +0000 (08:09 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Christian Tietz <christian.tietz@mailbox.org>
Closes: https://github.com/gentoo/gentoo/pull/13445
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-editors/gummi/Manifest
app-editors/gummi/gummi-0.7.999.ebuild [new file with mode: 0644]

index 251c8bfc522feff7f5a440f727f8595566301f8d..e8b0584419d58327e5c8dc643ae76fb12826e56d 100644 (file)
@@ -1 +1,2 @@
 DIST gummi-0.6.6.tar.gz 792642 BLAKE2B 4f6096999b06361811a9149fa08eff5d2315f01e55539c5849c4bc86aab5a482ad9a0adfe84de5d093e66a328b294b4d88e1e2e2f0355bab320f0c094581da97 SHA512 3be94927c9aafa4914ed2b6f6f5022dce5bcca315a1f947fafb8a4c8bbc5a2bc57f07f8ceaaacdd0b92a5a30483ea8b00e570faf62479280d2ad874716e4c47d
+DIST gummi-0.7.999.tar.gz 578026 BLAKE2B b3305560d621eab029f0931dfc9978d0883acb886d89d2f9e452a60e465a10736191987523c47fe9f5373d7dd7d112383ebf7eaf030e6f0751197e535e461708 SHA512 1da2171cbb26b8be71c34dd7b1bc025813d35604e465caf67e480c3356a706991e6dcaca3bc99bb862895e4597186850c7d4f203a81a9532a4cd742cd2744dc1
diff --git a/app-editors/gummi/gummi-0.7.999.ebuild b/app-editors/gummi/gummi-0.7.999.ebuild
new file mode 100644 (file)
index 0000000..1b970f9
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="https://github.com/alexandervdm/gummi"
+SRC_URI="https://github.com/alexandervdm/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+       app-text/gtkspell:3
+       app-text/poppler[cairo]
+       dev-libs/glib:2
+       dev-texlive/texlive-latex
+       dev-texlive/texlive-latexextra
+       x11-libs/gtk+:3
+       x11-libs/gtksourceview:3.0
+       x11-libs/pango
+"
+DEPEND="
+       ${RDEPEND}
+"
+BDEPEND="
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+pkg_postinst() {
+       xdg_desktop_database_update
+
+       elog "Gummi supports spell-checking through gtkspell. Support for"
+       elog "additional languages can be added by installing myspell-**-"
+       elog "packages for your language of choice."
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}