virtual/{blas,cblas,lapack,lapacke}: add virtual packages.
authorBenda Xu <heroxbd@gentoo.org>
Thu, 27 Jun 2019 05:41:31 +0000 (13:41 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Wed, 3 Jul 2019 12:30:39 +0000 (20:30 +0800)
  These virtual packages are used by the BLAS/LAPACK runtime switching
  mechanism.

Closes: https://github.com/gentoo/gentoo/pull/12323
Closes: https://bugs.gentoo.org/373613
Closes: https://bugs.gentoo.org/381801
Closes: https://bugs.gentoo.org/498490
Closes: https://bugs.gentoo.org/563674
Closes: https://bugs.gentoo.org/564546
Closes: https://bugs.gentoo.org/565776
Closes: https://bugs.gentoo.org/646316
Closes: https://bugs.gentoo.org/657984
Closes: https://bugs.gentoo.org/659014
Closes: https://bugs.gentoo.org/659264
Closes: https://bugs.gentoo.org/669644

Signed-off-by: Mo Zhou <cdluminate@gmail.com>
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
virtual/blas/blas-3.8.ebuild [new file with mode: 0644]
virtual/blas/metadata.xml
virtual/cblas/cblas-3.8.ebuild [new file with mode: 0644]
virtual/cblas/metadata.xml
virtual/lapack/lapack-3.8.ebuild [new file with mode: 0644]
virtual/lapack/metadata.xml
virtual/lapacke/lapacke-3.8.ebuild [new file with mode: 0644]
virtual/lapacke/metadata.xml [new file with mode: 0644]

diff --git a/virtual/blas/blas-3.8.ebuild b/virtual/blas/blas-3.8.ebuild
new file mode 100644 (file)
index 0000000..e3807aa
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Virtual for FORTRAN 77 BLAS implementation"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="eselect-ldso"
+
+RDEPEND="
+       >=sci-libs/lapack-3.8.0[eselect-ldso?]
+"
+DEPEND="${RDEPEND}"
index 1b4d6e817c05fd4c54e13ff962bed04353caed0d..35dd50fb44504f977048122283a429339728e702 100644 (file)
@@ -6,7 +6,11 @@
     <name>Gentoo Science Project</name>
   </maintainer>
   <longdescription lang="en">
-Gentoo virtual package for the Basic Linear Algebra Subprograms
-FORTRAN 77 implementation.
-</longdescription>
+    Gentoo virtual package for the Basic Linear Algebra Subprograms
+    FORTRAN 77 implementation.
+  </longdescription>
+  <use>
+    <flag name="eselect-ldso">Enable runtime library switching by
+    eselect and ld.so.</flag>
+  </use>
 </pkgmetadata>
diff --git a/virtual/cblas/cblas-3.8.ebuild b/virtual/cblas/cblas-3.8.ebuild
new file mode 100644 (file)
index 0000000..0b29596
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Virtual for BLAS C implementation"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="eselect-ldso"
+
+RDEPEND="
+       >=sci-libs/lapack-3.8.0[eselect-ldso?]
+"
+DEPEND="${RDEPEND}"
index 9aac1c20c93f61a1b928d8840beacf8eb2c1ec1f..204ea7552ca95a69cd6feb6d19649d5d255859cf 100644 (file)
@@ -6,7 +6,11 @@
     <name>Gentoo Science Project</name>
   </maintainer>
   <longdescription lang="en">
-Gentoo virtual package for the Basic Linear Algebra Subprograms
-C implementation.
-</longdescription>
+    Gentoo virtual package for the Basic Linear Algebra Subprograms
+    C implementation.
+  </longdescription>
+  <use>
+    <flag name="eselect-ldso">Enable runtime library switching by
+    eselect and ld.so.</flag>
+  </use>
 </pkgmetadata>
diff --git a/virtual/lapack/lapack-3.8.ebuild b/virtual/lapack/lapack-3.8.ebuild
new file mode 100644 (file)
index 0000000..93ddd49
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for Linear Algebra Package FORTRAN 77 (LAPACK) implementation"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="eselect-ldso"
+
+RDEPEND="
+       >=sci-libs/lapack-3.8.0[eselect-ldso?]
+"
+DEPEND="${RDEPEND}"
index ccb7a1fa1fad8161388f52f0d42fc74d3402990c..0b91d851efe1cf6160adf2e0fb4cf800ec8adabd 100644 (file)
@@ -6,7 +6,11 @@
     <name>Gentoo Science Project</name>
   </maintainer>
   <longdescription lang="en">
-Gentoo virtual package for the Linear Algebra PACKAge
-FORTRAN 77 implementation.
-</longdescription>
+    Gentoo virtual package for the Linear Algebra PACKAge
+    FORTRAN 77 implementation.
+  </longdescription>
+  <use>
+    <flag name="eselect-ldso">Enable runtime library switching by
+    eselect and ld.so.</flag>
+  </use>
 </pkgmetadata>
diff --git a/virtual/lapacke/lapacke-3.8.ebuild b/virtual/lapacke/lapacke-3.8.ebuild
new file mode 100644 (file)
index 0000000..fc61bf7
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for LAPACK C implementation"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="eselect-ldso"
+
+RDEPEND="
+       >=sci-libs/lapack-3.8.0[lapacke,eselect-ldso?]
+"
+DEPEND="${RDEPEND}"
diff --git a/virtual/lapacke/metadata.xml b/virtual/lapacke/metadata.xml
new file mode 100644 (file)
index 0000000..299f0ab
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>sci@gentoo.org</email>
+    <name>Gentoo Science Project</name>
+  </maintainer>
+  <longdescription lang="en">
+    Gentoo virtual package for the Linear Algebra PACKAge C
+    implementation.
+  </longdescription>
+  <use>
+    <flag name="eselect-ldso">Enable runtime library switching by
+    eselect and ld.so.</flag>
+  </use>
+</pkgmetadata>