dev-python/pypy: Fix install after eclass changes
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 20:09:52 +0000 (21:09 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 20:31:15 +0000 (21:31 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pypy/pypy-7.3.0.ebuild

index fef3e9c742c728d8c4f1d25040acc9a5a78fb354..15a4ffa994552c255f7843628a808d94914a6565 100644 (file)
@@ -170,17 +170,13 @@ src_install() {
                        "${ED}${dest}"/lib-python/*2.7/test/test_{tcl,tk,ttk*}.py || die
        fi
 
+       local -x EPYTHON=pypy
        local -x PYTHON=${ED}${dest}/pypy-c
-       # we can't use eclass function since PyPy is dumb and always gives
-       # paths relative to the interpreter
-       local PYTHON_SITEDIR=${EPREFIX}/usr/lib/pypy2.7/site-packages
-       python_export pypy EPYTHON
 
        echo "EPYTHON='${EPYTHON}'" > epython.py || die
+       python_moduleinto /usr/lib/pypy2.7/site-packages
        python_domodule epython.py
 
        einfo "Byte-compiling Python standard library..."
-
-       # compile the installed modules
        python_optimize "${ED}${dest}"
 }