dev-python/werkzeug: Version bump to 0.15.4
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 12 Jul 2019 17:48:19 +0000 (10:48 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 12 Jul 2019 17:52:24 +0000 (10:52 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/werkzeug/Manifest
dev-python/werkzeug/werkzeug-0.15.4.ebuild [new file with mode: 0644]

index 5e9a421b20993aeff52db2267b903da164752c22..a805a1d3a445f9bb6aa99ecef4591338afbe0578 100644 (file)
@@ -1,2 +1,3 @@
 DIST Werkzeug-0.12.2.tar.gz 1169770 BLAKE2B 12e7e422e7dae0ab2fc3cc52f80536362dea8edd61cdaec45a6cca35b789d731408e10cc46288b0c5c22138e20e9d52a88c2db78d22a215d5ab4bb9477526fcc SHA512 9ff45aeb51a71fd5115e8cdee40a7b2fddfa0574c356686050cb1bdced5c6c18f672b601ca2637010c7f59be75c66ee558efb4ea05052c550ec7da3644b88e0a
 DIST Werkzeug-0.14.1.tar.gz 1185546 BLAKE2B 4c358688752adce870e8b44ffede56e44ab26990f12c98cc75a7c7e0d40b1f39f4208237ed26a2acb1f78a3359272cb44bab4606c5bca55a5c5f5edfa22c9faa SHA512 64976cc46c1cee2203112c50aba6f9404d4e48d4a90f8b11837148b5415a28572b7e706095586045a46879e853fc5a80c63e7bf0c13eda29d564a37b4a554c0b
+DIST Werkzeug-0.15.4.tar.gz 925334 BLAKE2B ffb132026e5a43bdbbb6decf19c47b07bb38afe383fc6b769a793f9e72769bdb5a9507918590d485b9a84e8db392202fe985b0cd1fa00e8af17eccbf53bcdaec SHA512 b27b313cb29128ad1a1d0b04be7d1b29eacd4fb8280757510ce662b4f8743e7311966f7fb170531bd5dcb9668e9c6672f0cc0cf53bb4af3ec7328312a88b53ab
diff --git a/dev-python/werkzeug/werkzeug-0.15.4.ebuild b/dev-python/werkzeug/werkzeug-0.15.4.ebuild
new file mode 100644 (file)
index 0000000..0b9d425
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.org/project/Werkzeug/ https://github.com/pallets/werkzeug"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/requests[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+       )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile() {
+       distutils-r1_python_compile
+}
+
+python_test() {
+       pytest -vv tests || die "Tests failed under ${EPYTHON}"
+}