x11-libs/cairo: Drop directfb support
authorMatt Turner <mattst88@gentoo.org>
Fri, 29 Dec 2017 18:40:57 +0000 (13:40 -0500)
committerMatt Turner <mattst88@gentoo.org>
Fri, 29 Dec 2017 18:42:24 +0000 (13:42 -0500)
Has been masked since late 2014.

Bug: https://bugs.gentoo.org/642516

profiles/base/package.use.mask
x11-libs/cairo/cairo-1.14.10.ebuild
x11-libs/cairo/cairo-1.14.12.ebuild
x11-libs/cairo/cairo-1.14.8.ebuild
x11-libs/cairo/cairo-9999.ebuild

index 3d4894937bc198743d2b26ca4713b1606c3ae95c..dd7fe22d001673be2608e9c67be9e09e43f4e5cb 100644 (file)
@@ -424,11 +424,6 @@ dev-db/mysql cluster
 # is implemented. Masking for testing and evaluation.
 app-admin/clsync cluster mhash
 
-# Michał Górny <mgorny@gentoo.org> (30 Nov 2014)
-# Not supported at the moment. DirectFB lacks multilib support,
-# and we have to decide if we want it.
-x11-libs/cairo directfb
-
 # Brian Evans <grknight@gentoo.org> (29 Nov 2014)
 # Strongly recommened by upstream to disable lzo and zlib due to memory leaks
 # https://github.com/groonga/groonga/issues/6 (Japanese)
index 396118fc0619dcfb6f413dc01d2ff591e6f184a8..a6ea82e1c3643c826f03b2445c047b67541ca4e0 100644 (file)
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
 HOMEPAGE="https://www.cairographics.org"
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg valgrind xcb"
 # gtk-doc regeneration doesn't seem to work with out-of-source builds
 #[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
 
@@ -32,7 +32,6 @@ RDEPEND=">=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
        sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
        >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
        >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
-       directfb? ( dev-libs/DirectFB )
        gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
        glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
        opengl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
@@ -64,10 +63,6 @@ REQUIRED_USE="
        gles2? ( !opengl )
 "
 
-MULTILIB_WRAPPED_HEADERS=(
-       /usr/include/cairo/cairo-directfb.h
-)
-
 PATCHES=(
        "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
        "${FILESDIR}"/${PN}-respect-fontconfig.patch
@@ -99,12 +94,6 @@ multilib_src_configure() {
        use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
        [[ ${CHOST} == *-darwin* ]] && myopts+=" --disable-symbol-lookup"
 
-       # TODO: remove this (and add USE-dep) when DirectFB is converted,
-       # bug #484248 -- but beware of the circular dep.
-       if ! multilib_is_native_abi; then
-               myopts+=" --disable-directfb"
-       fi
-
        # TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
        if ! multilib_is_native_abi; then
                myopts+=" --disable-qt"
@@ -122,7 +111,6 @@ multilib_src_configure() {
                $(use_enable aqua quartz) \
                $(use_enable aqua quartz-image) \
                $(use_enable debug test-surfaces) \
-               $(use_enable directfb) \
                $(use_enable gles2 glesv2) \
                $(use_enable glib gobject) \
                $(use_enable opengl gl) \
@@ -135,6 +123,7 @@ multilib_src_configure() {
                --enable-pdf \
                --enable-png \
                --enable-ps \
+               --disable-directfb \
                --disable-drm \
                --disable-gallium \
                --disable-qt \
index 396118fc0619dcfb6f413dc01d2ff591e6f184a8..1d8b4ec96d4ddd7e669488ca48806a0d249fc4b7 100644 (file)
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
 HOMEPAGE="https://www.cairographics.org"
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg valgrind xcb"
 # gtk-doc regeneration doesn't seem to work with out-of-source builds
 #[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
 
@@ -32,7 +32,6 @@ RDEPEND=">=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
        sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
        >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
        >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
-       directfb? ( dev-libs/DirectFB )
        gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
        glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
        opengl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
@@ -64,10 +63,6 @@ REQUIRED_USE="
        gles2? ( !opengl )
 "
 
-MULTILIB_WRAPPED_HEADERS=(
-       /usr/include/cairo/cairo-directfb.h
-)
-
 PATCHES=(
        "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
        "${FILESDIR}"/${PN}-respect-fontconfig.patch
@@ -99,12 +94,6 @@ multilib_src_configure() {
        use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
        [[ ${CHOST} == *-darwin* ]] && myopts+=" --disable-symbol-lookup"
 
-       # TODO: remove this (and add USE-dep) when DirectFB is converted,
-       # bug #484248 -- but beware of the circular dep.
-       if ! multilib_is_native_abi; then
-               myopts+=" --disable-directfb"
-       fi
-
        # TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
        if ! multilib_is_native_abi; then
                myopts+=" --disable-qt"
@@ -122,7 +111,6 @@ multilib_src_configure() {
                $(use_enable aqua quartz) \
                $(use_enable aqua quartz-image) \
                $(use_enable debug test-surfaces) \
-               $(use_enable directfb) \
                $(use_enable gles2 glesv2) \
                $(use_enable glib gobject) \
                $(use_enable opengl gl) \
@@ -136,6 +124,7 @@ multilib_src_configure() {
                --enable-png \
                --enable-ps \
                --disable-drm \
+               --disable-directfb \
                --disable-gallium \
                --disable-qt \
                --disable-vg \
index e36dbac0a735bffc819c1365792c4ba38519462f..0d661077e6fd7a4d8e69cce05ac81ae8dda670ab 100644 (file)
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
 HOMEPAGE="https://www.cairographics.org"
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg valgrind xcb"
 # gtk-doc regeneration doesn't seem to work with out-of-source builds
 #[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
 
@@ -32,7 +32,6 @@ RDEPEND=">=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
        sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
        >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
        >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
-       directfb? ( dev-libs/DirectFB )
        gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
        glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
        opengl? ( || ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] media-libs/opengl-apple ) )
@@ -64,10 +63,6 @@ REQUIRED_USE="
        gles2? ( !opengl )
 "
 
-MULTILIB_WRAPPED_HEADERS=(
-       /usr/include/cairo/cairo-directfb.h
-)
-
 PATCHES=(
        "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
        "${FILESDIR}"/${PN}-respect-fontconfig.patch
@@ -99,12 +94,6 @@ multilib_src_configure() {
        use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
        [[ ${CHOST} == *-darwin* ]] && myopts+=" --disable-symbol-lookup"
 
-       # TODO: remove this (and add USE-dep) when DirectFB is converted,
-       # bug #484248 -- but beware of the circular dep.
-       if ! multilib_is_native_abi; then
-               myopts+=" --disable-directfb"
-       fi
-
        # TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
        if ! multilib_is_native_abi; then
                myopts+=" --disable-qt"
@@ -122,7 +111,6 @@ multilib_src_configure() {
                $(use_enable aqua quartz) \
                $(use_enable aqua quartz-image) \
                $(use_enable debug test-surfaces) \
-               $(use_enable directfb) \
                $(use_enable gles2 glesv2) \
                $(use_enable glib gobject) \
                $(use_enable opengl gl) \
@@ -136,6 +124,7 @@ multilib_src_configure() {
                --enable-png \
                --enable-ps \
                --disable-drm \
+               --disable-directfb \
                --disable-gallium \
                --disable-qt \
                --disable-vg \
index 9e0f4f744bfa88b763e78b82d2008bffc5bc46b0..7f294e891d560c467cced0a79a1157b0ed01904f 100644 (file)
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
 HOMEPAGE="https://www.cairographics.org"
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg utils valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind xcb"
 # gtk-doc regeneration doesn't seem to work with out-of-source builds
 #[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
 
@@ -32,7 +32,6 @@ RDEPEND="
        sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
        >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
        >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
-       directfb? ( dev-libs/DirectFB )
        gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
        glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
        opengl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
@@ -65,10 +64,6 @@ REQUIRED_USE="
        gles2? ( !opengl )
 "
 
-MULTILIB_WRAPPED_HEADERS=(
-       /usr/include/cairo/cairo-directfb.h
-)
-
 PATCHES=(
        "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
        "${FILESDIR}"/${PN}-respect-fontconfig.patch
@@ -99,12 +94,6 @@ multilib_src_configure() {
 
        use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
 
-       # TODO: remove this (and add USE-dep) when DirectFB is converted,
-       # bug #484248 -- but beware of the circular dep.
-       if ! multilib_is_native_abi; then
-               myopts+=" --disable-directfb"
-       fi
-
        # TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
        if ! multilib_is_native_abi; then
                myopts+=" --disable-qt"
@@ -122,7 +111,6 @@ multilib_src_configure() {
                $(use_enable aqua quartz) \
                $(use_enable aqua quartz-image) \
                $(use_enable debug test-surfaces) \
-               $(use_enable directfb) \
                $(use_enable gles2 glesv2) \
                $(use_enable glib gobject) \
                $(use_enable opengl gl) \
@@ -139,6 +127,7 @@ multilib_src_configure() {
                --enable-png \
                --enable-ps \
                --disable-drm \
+               --disable-directfb \
                --disable-gallium \
                --disable-qt \
                --disable-vg \