app-shells/bash-completion: Migrate to eapi7-ver
authorMichał Górny <mgorny@gentoo.org>
Thu, 6 Sep 2018 21:13:33 +0000 (23:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 6 Sep 2018 21:21:33 +0000 (23:21 +0200)
app-shells/bash-completion/bash-completion-2.8.ebuild
app-shells/bash-completion/bash-completion-9999.ebuild

index 13232e470d6035c4c87cf6f71f454b78d49c7e22..cd66da677fd9ff660c13911973d2c91f4a702c05 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=6
 
 BASHCOMP_P=bashcomp-2.0.2
-inherit versionator
+inherit eapi7-ver
 
 DESCRIPTION="Programmable Completion for bash"
 HOMEPAGE="https://github.com/scop/bash-completion"
@@ -112,7 +112,7 @@ src_install() {
 pkg_postinst() {
        local v
        for v in ${REPLACING_VERSIONS}; do
-               if ! version_is_at_least 2.1-r90 ${v}; then
+               if ver_test "${v}" -lt 2.1-r90; then
                        ewarn "For bash-completion autoloader to work, all completions need to"
                        ewarn "be installed in /usr/share/bash-completion/completions. You may"
                        ewarn "need to rebuild packages that installed completions in the old"
index 1ef70643b1e9e3c22a51c412d00fb14433272b73..79ee3e0ac0af627aa9cd8ce3c71857e4da0c5019 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 BASHCOMP_P=bashcomp-2.0.2
 EGIT_REPO_URI="https://github.com/scop/bash-completion"
-inherit autotools git-r3 versionator
+inherit autotools eapi7-ver git-r3
 
 DESCRIPTION="Programmable Completion for bash"
 HOMEPAGE="https://github.com/scop/bash-completion"
@@ -112,7 +112,7 @@ src_install() {
 pkg_postinst() {
        local v
        for v in ${REPLACING_VERSIONS}; do
-               if ! version_is_at_least 2.1-r90 ${v}; then
+               if ver_test "${v}" -lt 2.1-r90; then
                        ewarn "For bash-completion autoloader to work, all completions need to"
                        ewarn "be installed in /usr/share/bash-completion/completions. You may"
                        ewarn "need to rebuild packages that installed completions in the old"