www-servers/tomcat-8.5.47: bump
authorMiroslav Šulc <fordfrog@gentoo.org>
Wed, 16 Oct 2019 09:37:36 +0000 (11:37 +0200)
committerMiroslav Šulc <fordfrog@gentoo.org>
Wed, 16 Oct 2019 09:37:58 +0000 (11:37 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
www-servers/tomcat/Manifest
www-servers/tomcat/files/tomcat-8.5.47-build.xml.patch [new file with mode: 0644]
www-servers/tomcat/tomcat-8.5.47.ebuild [new file with mode: 0644]

index 29f5215855e86ad160c1b300c8fa19215e9d85cf..8b56f4c6158e381d390f958838376df8d0e4d0c6 100644 (file)
@@ -2,6 +2,7 @@ DIST apache-tomcat-7.0.96-src.tar.gz 4983881 BLAKE2B d5b828b7a4e8a7a5ce793a15421
 DIST apache-tomcat-8.5.43-src.tar.gz 5283886 BLAKE2B 2d76e66eedf4de474d439289a9a491e5c490e2373bc91ae30113b8f3c624255339d24149b58fba640aaf3131ab3c9a449930049d26928627e1b7910f0cddd40f SHA512 f6a0439dbfd3f233bd1eb395d37466ba2cce32cd456d067fb2bb45099ac173dec7e42e7fbfab2cb50c0fce2e9dba1f1afe6c8d65877525cb13cb116489cf27a7
 DIST apache-tomcat-8.5.45-src.tar.gz 5324847 BLAKE2B 5ef3388b9324bb04772543c03686057b3035f5a5f40009d0aa1ec34fe18d04af87527bcc9ae0566f41faf64de8ce191f8ea4e2ed2869da569777621aad227d6c SHA512 1fe94b9d5ccf63d2c5fc3dd7a47dabade160ed2882848e0a41422b5a67215d53e8265535ee8e645157d56c4eba9093722982684be6668064648b0782fc48927a
 DIST apache-tomcat-8.5.46-src.tar.gz 5599021 BLAKE2B 3755f15612e63ac06cbfa097f1531dc36542ba559a6ef60230b133e45d14bb4c4c54d4dcc8b05b9996f54ac253fb1630f6a6e900ee00e4af0a9200f83455a952 SHA512 02e93cc6fb4226e81b03ae60f479e15b438b1c68c1a4104200db9cc473939b92d66eea12f0783727b06f643d11ebe3da2a81c80cbe486ed497a3280e8cdb2e62
+DIST apache-tomcat-8.5.47-src.tar.gz 5607118 BLAKE2B 3c326056f674032424d298c7581243a24dd01fae39b1ce7069b60e1bcf3d825de954164f643e887618c43c87d691bc41f942e73bf86b254b4c7dca9c68ce7cce SHA512 1513fdaf7751ee263d878cdfc05329bc4ee50e2f3aeea68e1d173a5f4d555ec59a43050222f013758f704967730dd25a64337cf1ba4365ab53b8730af87b4051
 DIST apache-tomcat-9.0.24-src.tar.gz 5746934 BLAKE2B fe0ff76fd8b3caa2860c0798d66f0dfff1e907ca02d10913c768d8513b207ef11e8fe885cd7578348136b8d007e08ccc2044952198259ffcdb2d58acf9fbb8b6 SHA512 de11d0e992cce08edb83474bd4cab04857e3e2bf63ef334c8c9f3ad053edcc76691e831cc95b8c489b820773a6fa5d2755837b470d73471f9587bb7062d75a31
 DIST apache-tomcat-9.0.26-src.tar.gz 5750303 BLAKE2B 582acae0f24cab5fdd44c085b36e771508020d124f9329036b3bf0698da1fb2cda69d6f4254eeaca00ce3c34c3740fe69c077637107167fface60b9fa74c8869 SHA512 8f430439c66f5a43c7a35bc99edd11549100be28b17fb44e17ec432f72e1797cdebd641a7f19c1d918635e51c164ecd1c9d1399a63abfce05d9a8c37db381837
 DIST apache-tomcat-9.0.7-src.tar.gz 5106551 BLAKE2B b4552146a40c2e7cbb2e454fb5ec9169425db5c08cf269c391ec3144425ad388a2b6f003a7c05f59a9fd724fb5c848102890a24fcfd43d5fea3d881141aa7798 SHA512 cb7dc5547671d94f7c7fb0b58eeb94d05128349cdabf576fc8ad837a4bf3ea655a8eab3342245dfa84a9db23f1cbee2918846eedd48e3ca372eecebfef13c5b2
diff --git a/www-servers/tomcat/files/tomcat-8.5.47-build.xml.patch b/www-servers/tomcat/files/tomcat-8.5.47-build.xml.patch
new file mode 100644 (file)
index 0000000..ffbd070
--- /dev/null
@@ -0,0 +1,259 @@
+diff --git a/build.xml b/build.xml
+index c274aab..ed1c3e5 100644
+--- a/build.xml
++++ b/build.xml
+@@ -739,24 +739,29 @@
+       manifest="${tomcat.manifests}/annotations-api.jar.manifest" />
+     <!-- Servlet 3.1 Implementation JAR File -->
++<!--
+     <jarIt jarfile="${servlet-api.jar}"
+       filesDir="${tomcat.classes}"
+       filesId="files.servlet-api"
+       manifest="${tomcat.manifests}/servlet-api.jar.manifest"
+       notice="${tomcat.manifests}/servlet-api.jar.notice"
+       license="${tomcat.manifests}/servlet-api.jar.license" />
+-
++-->
+     <!-- JSP 2.3 Implementation JAR File -->
++<!--
+     <jarIt jarfile="${jsp-api.jar}"
+       filesDir="${tomcat.classes}"
+       filesId="files.jsp-api"
+       manifest="${tomcat.manifests}/jsp-api.jar.manifest" />
++-->
+     <!-- EL 3.0 Implementation JAR File -->
++<!--
+     <jarIt jarfile="${el-api.jar}"
+       filesDir="${tomcat.classes}"
+       filesId="files.el-api"
+       manifest="${tomcat.manifests}/el-api.jar.manifest" />
++-->
+     <!-- WebSocket 1.1 API JAR File -->
+     <jarIt jarfile="${websocket-api.jar}"
+@@ -848,9 +853,9 @@
+       filesId="files.jasper-el" />
+     <!-- Re-packaged Apache Commons DBCP 2-->
+-    <jarIt jarfile="${tomcat-dbcp.jar}"
++<!--    <jarIt jarfile="${tomcat-dbcp.jar}"
+       filesDir="${tomcat.classes}"
+-      filesId="files.tomcat-dbcp" />
++      filesId="files.tomcat-dbcp" /> -->
+     <!-- i18n JARs -->
+     <jar jarfile="${tomcat.build}/lib/tomcat-i18n-de.jar"
+@@ -1072,9 +1077,9 @@
+   <target name="deploy" depends="package,build-docs,build-tomcat-jdbc,compile-webapp-examples"
+           description="Default. Builds a working Tomcat instance">
+-
++<!--
+     <copy tofile="${tomcat.build}/bin/commons-daemon.jar" file="${commons-daemon.jar}" />
+-
++-->
+     <!-- Copy scripts -->
+     <copy todir="${tomcat.build}/bin">
+       <fileset dir="bin">
+@@ -1134,7 +1139,7 @@
+         <exclude name="${jdt.jar.filename}"/>
+       </fileset>
+     </delete>
+-    <copy file="${jdt.jar}" todir="${tomcat.build}/lib"/>
++<!--    <copy file="${jdt.jar}" todir="${tomcat.build}/lib"/> -->
+     <!-- Add sources for examples -->
+     <antcall target="examples-sources" />
+@@ -1177,7 +1182,7 @@
+   </target>
+-  <target name="build-tomcat-jdbc" depends="package">
++  <target name="build-tomcat-jdbc" depends="package" unless="noget">
+     <!-- build the jdbc-pool jar and source jar-->
+     <echo message="Building Tomcat JDBC pool libraries"/>
+     <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
+@@ -1192,7 +1197,7 @@
+     <copy file="${tomcat-jdbc.jar}" todir="${tomcat.build}/lib"/>
+   </target>
+-  <target name="build-tomcat-jdbc-src">
++  <target name="build-tomcat-jdbc-src" unless="noget">
+     <!-- build the jdbc-pool source jar-->
+     <echo message="Building Tomcat JDBC pool src JAR"/>
+     <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
+@@ -1295,9 +1300,11 @@
+     <copy file="${basedir}/LICENSE" todir="${tomcat.embed}" />
+     <copy file="${basedir}/NOTICE" todir="${tomcat.embed}" />
++<!--
+     <copy file="${tomcat-dbcp.jar}" todir="${tomcat.embed}"
+       failonerror="false"/>
+     <copy file="${jdt.jar}" todir="${tomcat.embed}" />
++-->
+     <copy file="${annotations-api.jar}" todir="${tomcat.embed}" />
+     <!-- Note the meta-inf below will work as long as there is only one JAR
+@@ -1681,7 +1688,7 @@
+   <target name="extras-webservices-prepare"
+           depends="extras-prepare"
+-          description="Prepare to build web services extras package">
++          description="Prepare to build web services extras package" unless="noget">
+     <antcall target="downloadfile">
+       <param name="sourcefile" value="${jaxrpc-lib.loc}"/>
+@@ -1845,6 +1852,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+   <target name="javadoc" depends="dist-source,extras-webservices-prepare"
+     description="Create the Tomcat javadoc" >
++<!--
+     <javadoc packagenames="javax.annotation.*"
+       sourcepath="${tomcat.dist}/src/java"
+       destdir="${tomcat.dist}/webapps/docs/annotationapi"
+@@ -1933,6 +1941,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+         <path location="${ant.core.lib}"/>
+       </classpath>
+     </javadoc>
++-->
+     <javadoc packagenames="javax.websocket.*"
+       sourcepath="${tomcat.dist}/src/java"
+       destdir="${tomcat.dist}/webapps/docs/websocketapi"
+@@ -1996,9 +2005,11 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+         <path location="${ant.core.lib}"/>
+       </classpath>
+       <link href="../annotationapi"/>
++<!--
+       <link href="../servletapi"/>
+       <link href="../jspapi"/>
+       <link href="../elapi"/>
++-->
+       <link href="../websocketapi"/>
+       <link href="../jaspicapi"/>
+       <link href="https://docs.oracle.com/javase/7/docs/api/"/>
+@@ -2728,7 +2739,7 @@ skip.installer property in build.properties" />
+   </target>
+   <target name="download-compile"
+-          description="Download components necessary to compile" >
++          description="Download components necessary to compile" unless="noget" >
+     <!-- Download Commons Daemon -->
+     <antcall target="downloadgz-2">
+@@ -2764,7 +2775,7 @@ skip.installer property in build.properties" />
+   </target>
+   <target name="download-test-compile"
+-          description="Download additional components for the tests" >
++          description="Download additional components for the tests" unless="noget">
+     <antcall target="downloadfile">
+       <param name="sourcefile" value="${junit.loc}"/>
+@@ -2842,7 +2853,7 @@ skip.installer property in build.properties" />
+   </target>
+   <target name="download-dist"
+-          description="Download additional components for a distribution" >
++          description="Download additional components for a distribution" unless="noget">
+     <antcall target="downloadfile-2">
+       <param name="sourcefile.1" value="${tomcat-native.loc.1}"/>
+@@ -2897,13 +2908,13 @@ skip.installer property in build.properties" />
+   <!-- =============== Utility Targets to support downloads ================ -->
+-  <target name="setproxy" if="${proxy.use}">
++  <target name="setproxy" if="${proxy.use}" unless="noget">
+     <setproxy proxyhost="${proxy.host}" proxyport="${proxy.port}"
+               proxyuser="${proxy.user}" proxypassword="${proxy.password}" />
+     <echo message="Using ${proxy.host}:${proxy.port} to download ${sourcefile}"/>
+   </target>
+-  <target name="testexist">
++  <target name="testexist" unless="noget">
+     <echo message="Testing  for ${destfile}"/>
+     <available file="${destfile}" property="exist"/>
+   </target>
+@@ -3025,7 +3036,7 @@ skip.installer property in build.properties" />
+     </sequential>
+   </macrodef>
+-  <target name="downloadgz" unless="exist" depends="testexist,setproxy">
++  <target name="downloadgz" unless="noget" depends="testexist,setproxy">
+     <!-- Download and extract the package -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -3042,7 +3053,7 @@ skip.installer property in build.properties" />
+     <delete file="${temp.file}.tar.gz"/>
+   </target>
+-  <target name="downloadgz-2" unless="exist" depends="testexist">
++  <target name="downloadgz-2" unless="noget" depends="testexist">
+     <!-- Download and extract the package from the two alternative locations -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -3067,7 +3078,7 @@ skip.installer property in build.properties" />
+     <delete file="${temp.file}.tar.gz"/>
+   </target>
+-  <target name="downloadzip" unless="exist" depends="testexist,setproxy">
++  <target name="downloadzip" unless="noget" depends="testexist,setproxy">
+     <!-- Download and extract the package -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -3083,7 +3094,7 @@ skip.installer property in build.properties" />
+     <delete file="${temp.file}"/>
+   </target>
+-  <target name="downloadzip-2" unless="exist" depends="testexist">
++  <target name="downloadzip-2" unless="noget" depends="testexist">
+     <!-- Download and extract the package from the two alternative locations -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -3107,7 +3118,7 @@ skip.installer property in build.properties" />
+     <delete file="${temp.file}"/>
+   </target>
+-  <target name="downloadfile" unless="exist" depends="testexist,setproxy">
++  <target name="downloadfile" unless="noget" depends="testexist,setproxy">
+     <!-- Download the file -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -3122,7 +3133,7 @@ skip.installer property in build.properties" />
+     <move file="${temp.file}" tofile="${destfile}"/>
+   </target>
+-  <target name="downloadfile-2" unless="exist" depends="testexist">
++  <target name="downloadfile-2" unless="noget" depends="testexist">
+     <!-- Download the file from the two alternative locations -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -3150,7 +3161,7 @@ skip.installer property in build.properties" />
+     <move file="${temp.file}" tofile="${destfile}"/>
+   </target>
+-  <target name="trydownload.check" depends="setproxy">
++  <target name="trydownload.check" depends="setproxy" unless="noget">
+     <condition property="trydownload.run">
+       <and>
+         <not>
+@@ -3161,7 +3172,7 @@ skip.installer property in build.properties" />
+     </condition>
+   </target>
+-  <target name="trydownload" if="trydownload.run" depends="trydownload.check">
++  <target name="trydownload" if="trydownload.run" depends="trydownload.check" unless="noget">
+     <!-- Downloads a file if not yet downloaded and the source URL is available -->
+     <get src="${sourcefile}" httpusecaches="${trydownload.httpusecaches}" dest="${destfile}" />
+   </target>
+@@ -3172,7 +3183,7 @@ skip.installer property in build.properties" />
+   <target name="ide-eclipse"
+           depends="download-compile, extras-webservices-prepare, download-test-compile"
+-          description="Prepares the source tree to be built in Eclipse">
++          description="Prepares the source tree to be built in Eclipse" unless="noget">
+     <!-- Copy the sample project files into the root directory -->
+     <copy file="${tomcat.home}/res/ide-support/eclipse/eclipse.project" tofile="${tomcat.home}/.project"/>
diff --git a/www-servers/tomcat/tomcat-8.5.47.ebuild b/www-servers/tomcat/tomcat-8.5.47.ebuild
new file mode 100644 (file)
index 0000000..5f75e72
--- /dev/null
@@ -0,0 +1,159 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-ant-2 prefix user
+
+MY_P="apache-${P}-src"
+
+DESCRIPTION="Tomcat Servlet-3.1/JSP-2.3/EL-3.0/WebSocket-1.1/JASPIC-1.1 Container"
+HOMEPAGE="https://tomcat.apache.org/"
+SRC_URI="mirror://apache/${PN}/tomcat-8/v${PV}/src/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="8.5"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="extra-webapps"
+
+RESTRICT="test" # can we run them on a production system?
+
+ECJ_SLOT="4.5"
+SAPI_SLOT="3.1"
+
+COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
+       >=dev-java/tomcat-servlet-api-${SLOT}:${SAPI_SLOT}"
+RDEPEND="${COMMON_DEP}
+       !<dev-java/tomcat-native-1.1.24
+       >=virtual/jre-1.8"
+DEPEND="${COMMON_DEP}
+       app-admin/pwgen
+       >=dev-java/ant-core-1.9.13
+       >=virtual/jdk-1.8
+       test? (
+               >=dev-java/ant-junit-1.9:0
+               dev-java/easymock:3.2
+       )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+       java-pkg-2_pkg_setup
+       enewgroup tomcat 265
+       enewuser tomcat 265 -1 /dev/null tomcat
+}
+
+src_prepare() {
+       default
+
+       find -name '*.jar' -type f -delete -print || die
+
+       # Remove bundled servlet-api
+       rm -rv java/javax/{el,servlet} || die
+
+       eapply "${FILESDIR}/${P}-build.xml.patch"
+
+       # For use of catalina.sh in netbeans
+       sed -i -e "/^# ----- Execute The Requested Command/ a\
+               CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
+               bin/catalina.sh || die
+
+       java-pkg-2_src_prepare
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_BUILD_TARGET="deploy"
+EANT_GENTOO_CLASSPATH="eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT}"
+EANT_TEST_GENTOO_CLASSPATH="easymock-3.2"
+EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
+EANT_NEEDS_TOOLS="true"
+EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false -Dexecute.validate=false"
+
+# revisions of the scripts
+IM_REV="-r2"
+INIT_REV="-r1"
+
+src_compile() {
+       EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
+       java-pkg-2_src_compile
+}
+
+src_test() {
+       java-pkg-2_src_test
+}
+
+src_install() {
+       local dest="/usr/share/${PN}-${SLOT}"
+
+       java-pkg_jarinto "${dest}"/bin
+       java-pkg_dojar output/build/bin/*.jar
+       exeinto "${dest}"/bin
+       doexe output/build/bin/*.sh
+
+       java-pkg_jarinto "${dest}"/lib
+       java-pkg_dojar output/build/lib/*.jar
+
+       dodoc RELEASE-NOTES RUNNING.txt
+       use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
+       use source && java-pkg_dosrc java/*
+
+       ### Webapps ###
+
+       # add missing docBase
+       local apps="host-manager manager"
+       for app in ${apps}; do
+               sed -i -e "s|=\"true\" >|=\"true\" docBase=\"\$\{catalina.home\}/webapps/${app}\" >|" \
+                       output/build/webapps/${app}/META-INF/context.xml || die
+       done
+
+       insinto "${dest}"/webapps
+       doins -r output/build/webapps/{host-manager,manager,ROOT}
+       use extra-webapps && doins -r output/build/webapps/{docs,examples}
+
+       ### Config ###
+
+       # create "logs" directory in $CATALINA_BASE
+       # and set correct perms, see #458890
+       dodir "${dest}"/logs
+       fperms 0750 "${dest}"/logs
+
+       # replace the default pw with a random one, see #92281
+       local randpw="$(pwgen -s -B 15 1)"
+       sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
+
+       # prepend gentoo.classpath to common.loader, see #453212
+       sed -i -e 's/^common\.loader=/\0${gentoo.classpath},/' output/build/conf/catalina.properties || die
+
+       insinto "${dest}"
+       doins -r output/build/conf
+
+       ### rc ###
+
+       cp "${FILESDIR}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} "${T}" || die
+       eprefixify "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash}
+       sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} || die
+
+       insinto "${dest}"/gentoo
+       doins "${T}"/tomcat.conf
+       exeinto "${dest}"/gentoo
+       newexe "${T}"/tomcat${INIT_REV}.init tomcat.init
+       newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
+}
+
+pkg_postinst() {
+       elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
+       elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
+       elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
+
+       elog "To manage Tomcat instances, run:"
+       elog "  ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
+
+       ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
+       ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
+
+       einfo "Please read https://wiki.gentoo.org/wiki/Apache_Tomcat and"
+       einfo "https://wiki.gentoo.org/wiki/Project:Java/Tomcat_6_Guide for more information."
+}