dev-python/pycuda: [QA] Fix MissingTestRestrict
authorMichał Górny <mgorny@gentoo.org>
Thu, 12 Dec 2019 15:32:58 +0000 (16:32 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 12 Dec 2019 16:34:29 +0000 (17:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pycuda/pycuda-2012.1.ebuild
dev-python/pycuda/pycuda-2013.1.1.ebuild
dev-python/pycuda/pycuda-2014.1.ebuild
dev-python/pycuda/pycuda-2016.1.2.ebuild
dev-python/pycuda/pycuda-2017.1.ebuild
dev-python/pycuda/pycuda-2018.1.1.ebuild
dev-python/pycuda/pycuda-9999.ebuild

index a2b3ca5a8819bb0ca1bc8dc0955ccf7eb249c218..21e49e486065f2a758175ada53f2c4c9c8c4b402 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
 
 # We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
 # user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
 
 python_prepare_all() {
        cuda_sanitize
index 64034046183c3a8581d2d7e66e8c5eba7f4c9082..46a77f6203c6070ce377990a1827869cbf65b818 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
 
 # We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
 # user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
 
 python_prepare_all() {
        cuda_sanitize
index 211eb6a76d775d14f9fe3289638d1326532d77e8..e72781d1161f35ad71ca86ca442e4f1fd8c3dbdb 100644 (file)
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
 
 # We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
 # user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
 
 python_prepare_all() {
        cuda_sanitize
index 4267fea04c09dde6c53d0d50cb7c9ac1cbaec8a4..9875a9045d8e32f540dbb2d8c1319bb657fb016e 100644 (file)
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
 
 # We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
 # user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
 
 python_prepare_all() {
        cuda_sanitize
index d0aeb99c15d1e789c82c0d14ccf9d56068cbd431..7cffaca82606103903feff1aaf46e82a60f2257e 100644 (file)
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
 
 # We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
 # user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
 
 python_prepare_all() {
        cuda_sanitize
index ea003a8275d76d7ce8ebfe6a03ce597ac43f6b37..23d3223f3ff7d56ff45046b264da47fef963b723 100644 (file)
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
 
 # We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
 # user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
 
 python_prepare_all() {
        cuda_sanitize
index b289dbcddc6be420a28fa5a13252b2e004ee5831..5b3ba1b64de06af0bf782dfa384e276dae81a8ed 100644 (file)
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
 
 # We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
 # user is (usually) not in the video group
-RESTRICT="userpriv"
+RESTRICT="userpriv !test? ( test )"
 
 python_prepare_all() {
        cuda_sanitize