media-libs/imlib2: fix build issue with 'doc' USE in 1.5.1-r1
authorJoonas Niilola <juippis@gmail.com>
Thu, 23 Aug 2018 14:08:50 +0000 (17:08 +0300)
committerMichał Górny <mgorny@gentoo.org>
Sat, 25 Aug 2018 06:12:36 +0000 (08:12 +0200)
Package-Manager: Portage[mgorny]-2.3.43.3
Closes: https://github.com/gentoo/gentoo/pull/9674

media-libs/imlib2/imlib2-1.5.1-r1.ebuild

index 54c743ce05e56ad987e576ed7aaf7e8694d5b19f..b324395625cea9bfffc8e2e7aca8ad38b4c3f439 100644 (file)
@@ -64,12 +64,13 @@ multilib_src_configure() {
 
 multilib_src_install() {
        V=1 emake install DESTDIR="${D}"
+       find "${D}" -name '*.la' -delete || die
+}
 
+multilib_src_install_all() {
        if use doc; then
                local HTML_DOCS=( "${S}"/doc/. )
                rm "${S}"/doc/Makefile.{am,in} || die
        fi
        einstalldocs
-
-       find "${D}" -name '*.la' -delete || die
 }