dev-php/pecl-ssh2: add php-7.1 support.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 8 Apr 2017 19:15:21 +0000 (15:15 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sat, 8 Apr 2017 19:27:24 +0000 (15:27 -0400)
Gentoo-Bug: 603508

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-php/pecl-ssh2/pecl-ssh2-1.0-r1.ebuild [moved from dev-php/pecl-ssh2/pecl-ssh2-1.0.ebuild with 57% similarity]
dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild

similarity index 57%
rename from dev-php/pecl-ssh2/pecl-ssh2-1.0.ebuild
rename to dev-php/pecl-ssh2/pecl-ssh2-1.0-r1.ebuild
index 43870a60730dcd7eb867a7409d11c4da4d8cc320..28dc40b3371e9a4e71bf82e07f4ebe9cab63ebfd 100644 (file)
@@ -1,17 +1,15 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 PHP_EXT_NAME="ssh2"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
 
-USE_PHP="php7-0 php5-6"
+USE_PHP="php5-6 php7-0 php7-1"
 
 inherit php-ext-pecl-r3
 
-USE_PHP="php7-0"
+USE_PHP="php7-0 php7-1"
 
 DESCRIPTION="PHP bindings for the libssh2 library"
 LICENSE="PHP-3.01"
@@ -19,11 +17,11 @@ SLOT="7"
 IUSE=""
 KEYWORDS="~amd64 ~x86"
 DEPEND=">=net-libs/libssh2-1.2"
-RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
-PHP_EXT_ECONF_ARGS=""
+RDEPEND="${DEPEND}
+       php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
 
 src_prepare() {
-       if use php_targets_php7-0 ; then
+       if use php_targets_php7-0 || use php_targets_php7-1; then
                php-ext-source-r3_src_prepare
        else
                default_src_prepare
index 1e571c0de962c57f25845bcbe7d728d3b4d09e08..ee9effc3e76a3ad07a440e9026752d1189f25071 100644 (file)
@@ -1,18 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 PHP_EXT_NAME="ssh2"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
 
-USE_PHP="php7-0 php5-6"
+USE_PHP="php5-6 php7-0 php7-1"
 EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
 
 inherit php-ext-source-r3 git-r3
 
-USE_PHP="php7-0"
+USE_PHP="php7-0 php7-1"
 
 DESCRIPTION="PHP bindings for the libssh2 library"
 LICENSE="PHP-3.01"
@@ -20,9 +18,9 @@ SLOT="7"
 IUSE=""
 KEYWORDS=""
 DEPEND=">=net-libs/libssh2-1.2"
-RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
+RDEPEND="${DEPEND}
+       php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
 HOMEPAGE="https://pecl.php.net/package/ssh2"
-PHP_EXT_ECONF_ARGS=""
 
 src_unpack() {
        git-r3_src_unpack
@@ -30,7 +28,7 @@ src_unpack() {
 }
 
 src_prepare() {
-       if use php_targets_php7-0 ; then
+       if use php_targets_php7-0 || use php_targets_php7-1 ; then
                php-ext-source-r3_src_prepare
        else
                default_src_prepare