x11-wm/dwm: Version bump
authorCédric Krier <cedk@gentoo.org>
Thu, 1 Feb 2007 19:44:06 +0000 (19:44 +0000)
committerCédric Krier <cedk@gentoo.org>
Thu, 1 Feb 2007 19:44:06 +0000 (19:44 +0000)
Package-Manager: portage-2.1.1-r2

x11-wm/dwm/ChangeLog
x11-wm/dwm/dwm-3.3.ebuild [new file with mode: 0644]
x11-wm/dwm/files/digest-dwm-3.3 [new file with mode: 0644]

index 98250a8506f8c87b2bb712d3a9616231e20132ca..b34aa34ca9472dbba5701066918c8e3895fea767 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-wm/dwm
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.10 2007/01/28 17:34:58 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.11 2007/02/01 19:44:06 cedk Exp $
+
+*dwm-3.3 (01 Feb 2007)
+
+  01 Feb 2007; Cedric Krier <cedk@gentoo.org> -dwm-3.1.ebuild,
+  +dwm-3.3.ebuild:
+  Version bump
 
   28 Jan 2007; Cedric Krier <cedk@gentoo.org> dwm-3.1.ebuild,
   dwm-3.2.2.ebuild:
diff --git a/x11-wm/dwm/dwm-3.3.ebuild b/x11-wm/dwm/dwm-3.3.ebuild
new file mode 100644 (file)
index 0000000..3b1174f
--- /dev/null
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-3.3.ebuild,v 1.1 2007/02/01 19:44:06 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://dwm.suckless.org/"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="savedconfig"
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       sed -i \
+               -e "s/.*strip.*//" \
+               Makefile || die "sed failed"
+
+       sed -i \
+               -e "s/CFLAGS = -Os/CFLAGS +=/" \
+               -e "s/LDFLAGS =/LDFLAGS +=/" \
+               config.mk || die "sed failed"
+
+       if use savedconfig; then
+               local conf root
+               [[ -r config.h ]] && rm config.h
+               for conf in ${PF} ${P} ${PN}; do
+                       for root in "${PORTAGE_CONFIGROOT}" "${ROOT}" /; do
+                               configfile=${root}etc/portage/savedconfig/${conf}.config.h
+                               if [[ -r ${configfile} ]]; then
+                                       elog "Found your ${configfile} and using it."
+                                       cp ${configfile} "${S}"/config.h
+                                       return 0
+                               fi
+                       done
+               done
+               ewarn "Could not locate user configfile, so we will save a default one."
+       fi
+}
+
+src_compile() {
+       local msg
+       use savedconfig && msg=", please check the configfile"
+       emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+       insinto /usr/share/${PN}
+       newins config.h ${PF}.config.h
+
+       exeinto /etc/X11/Sessions
+       newexe "${FILESDIR}"/dwm-session dwm
+
+       insinto /usr/share/xsessions
+       doins "${FILESDIR}"/dwm.desktop
+
+       dodoc README
+}
+
+pkg_preinst() {
+       if use savedconfig; then
+               mv "${D}"/usr/share/${PN}/${PF}.config.h "${T}"/ || die
+       fi
+}
+
+pkg_postinst() {
+       if use savedconfig; then
+               local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+               elog "Saving this build config to ${config_dir}/${PF}.config.h"
+               einfo "Read this ebuild for more info on how to take advantage of this option."
+               mkdir -p "${config_dir}"
+               cp "${T}"/${PF}.config.h "${config_dir}"/${PF}.config.h
+       fi
+       einfo "This ebuild has support for user defined configs"
+       einfo "Please read this ebuild for more details and re-emerge as needed"
+       einfo "if you want to add or remove functionality for ${PN}"
+       if ! has_version x11-misc/dmenu; then
+               elog "Installing ${PN} without x11-misc/dmenu"
+               einfo "To have a menu you can install x11-misc/dmenu"
+       fi
+       einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+       einfo "the ouput is redirected to the standard input of dwm"
+}
diff --git a/x11-wm/dwm/files/digest-dwm-3.3 b/x11-wm/dwm/files/digest-dwm-3.3
new file mode 100644 (file)
index 0000000..fc179fc
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 8095a0df3a8ea41129613473c00466a0 dwm-3.3.tar.gz 17450
+RMD160 90b27981b28285461f130fb370a6c6abeefd6a08 dwm-3.3.tar.gz 17450
+SHA256 caffe5ce38c8575341296b7a3f05f2e8b64763da0f288c16951f97a386cc081c dwm-3.3.tar.gz 17450