sys-firmware/seabios: add USE=debug to control debug output levels
authorMike Frysinger <vapier@gentoo.org>
Sun, 30 Aug 2015 00:27:14 +0000 (20:27 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sun, 30 Aug 2015 00:27:14 +0000 (20:27 -0400)
sys-firmware/seabios/seabios-1.8.2.ebuild

index 61b1a8d77671a46333e94fc1b29fadd0f8fe5056..23e935b8e815ed1b9c2e78c217e3f268542154ad 100644 (file)
@@ -32,9 +32,10 @@ HOMEPAGE="http://www.seabios.org"
 
 LICENSE="LGPL-3 GPL-3"
 SLOT="0"
-IUSE="+binary +seavgabios"
+IUSE="+binary debug +seavgabios"
 
-REQUIRED_USE="ppc? ( binary )
+REQUIRED_USE="debug? ( !binary )
+       ppc? ( binary )
        ppc64? ( binary )"
 
 DEPEND="
@@ -73,7 +74,14 @@ src_prepare() {
 }
 
 src_configure() {
-       use binary || tc-ld-disable-gold #438058
+       use binary && return
+
+       tc-ld-disable-gold #438058
+
+       if use debug ; then
+               echo "CONFIG_DEBUG_LEVEL=8" >.config
+       fi
+       _emake config
 }
 
 _emake() {