dev-python/oslo-config: 6.8.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 05:28:17 +0000 (00:28 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:05:05 +0000 (02:05 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/oslo-config/Manifest
dev-python/oslo-config/oslo-config-6.8.1.ebuild [new file with mode: 0644]

index f58818f9ab4a39790e9241df1b691722758e48e0..58dd6fd4ecbca194aa1dfe8f2b822d2231e70e76 100644 (file)
@@ -1 +1,2 @@
 DIST oslo-config-6.4.1.tar.gz 144762 BLAKE2B 467e139767b6afd82e1c0d39841765c93e4c23b208e676bfd4c64512a71f6c432a1431d5bf902d268152fa3011e864173f6a766bca560efaadce7a713fa919b7 SHA512 97a47931fe98c6a19ecfe38fa8aae50e91e955db879b96988560db16c0ec775ce294cf0c9b45e62aa7dea67ec43cbfebf4a77e168f0c348bb03066c832dc40a3
+DIST oslo-config-6.8.1.tar.gz 149525 BLAKE2B 0676ac364410c5d2eb6c4d75b85c18d0cbb50cff33954a2afc96f4f779606912d46c0627b0d77fd63795f43e26baab113cfba409eb86e5a8c8353253542bdecb SHA512 d861120e35332411e7caba1ce1b37a2ad16d986ff2063d731edfa0cd6603000fd7f1abf6ebb611c7efbb6d3c4296c0ffb9ccea2c2cd6ba6bf7b18c53daa09f15
diff --git a/dev-python/oslo-config/oslo-config-6.8.1.ebuild b/dev-python/oslo-config/oslo-config-6.8.1.ebuild
new file mode 100644 (file)
index 0000000..158aaee
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Configuration API"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+               >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/requests-mock-1.5.0[${PYTHON_USEDEP}]
+               >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+       )
+       doc? (
+               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+       >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+       >=dev-python/rfc3986-1.2.0[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+       virtual/python-enum34[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       use doc && esetup.py build_sphinx
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       rm -rf .testrepository || die "could not remove '.testrepository' under ${EPTYHON}"
+
+       testr init || die "testr init failed under ${EPYTHON}"
+       testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+
+       distutils-r1_python_install_all
+}