sys-cluster/swift: clarify the kernel check
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 24 Mar 2020 02:05:03 +0000 (21:05 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 24 Mar 2020 02:05:20 +0000 (21:05 -0500)
Closes: https://bugs.gentoo.org/713654
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
sys-cluster/swift/swift-2019.2.9999.ebuild

index dfb4786356f76c0f8ea4a980009ba17ccc1f6902..afeeb15cce388f2e24bef7d4450ba72b90088d8a 100644 (file)
@@ -46,12 +46,11 @@ RDEPEND="
 
 pkg_pretend() {
        linux-info_pkg_setup
-       CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
-       ~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
-       ~ZFS"
+       CONFIG_CHECK="~EXT3_FS_XATTR ~CIFS_XATTR ~TMPFS_XATTR ~UBIFS_FS_XATTR
+       ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR ~ZFS"
        if linux_config_exists; then
                for module in ${CONFIG_CHECK}; do
-                       linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
+                       linux_chkconfig_present ${module} || ewarn "you may want to enable the ${module} module"
                done
        fi
 }