sci-libs/ogdi: 4.1.0 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 11:14:33 +0000 (13:14 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 11:30:49 +0000 (13:30 +0200)
Bug: https://bugs.gentoo.org/699838
Closes: https://bugs.gentoo.org/706190
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-libs/ogdi/Manifest
sci-libs/ogdi/files/ogdi-4.1.0-subdirs.patch [new file with mode: 0644]
sci-libs/ogdi/ogdi-4.1.0.ebuild [new file with mode: 0644]

index e10d38f7e8a271fb92651991675a49d36a956e96..3e06551d6aa517ce2a2a05c06f3fddbabb286759 100644 (file)
@@ -1 +1,2 @@
 DIST ogdi-3.2.0.tar.gz 976004 BLAKE2B 535f05b3145c49ce72adcd86cd9ded1c8d8d12e051feb4e1898d8ddabbff1cf27f609326ccdb3a1cbff523b277f99e9d8c3678d2ed565dd81e6c5d956ed2dcca SHA512 b29d52b733c15927d2c93df10632d9bf6288614b944c02a5e1a67f3f971263bcb07460b301fb5db389ed15fc5f38a1f3c0263c4b1441f2ea4809bb61b3e67ef0
+DIST ogdi-4.1.0.tar.gz 848818 BLAKE2B d037d7a1b97e0db4b714e94a46c04e7126b5ab520e9cf54ffaba5f3e8ffa694690f4863ce257a4f56a3a596ae3ce430eb8f656f700a9287455b9f540299c6b1a SHA512 abfc409bfa5ea2f81a90c16361fe6cdc2b2ee39775c22ceb74b13b171aa04d6d6eaffe398cae0ef91dcde8509e5cc25100eedeffdad358e090b78e118d386859
diff --git a/sci-libs/ogdi/files/ogdi-4.1.0-subdirs.patch b/sci-libs/ogdi/files/ogdi-4.1.0-subdirs.patch
new file mode 100644 (file)
index 0000000..208bfb2
--- /dev/null
@@ -0,0 +1,24 @@
+diff -urN a/makefile b/makefile
+--- a/makefile
++++ b/makefile
+@@ -17,7 +17,7 @@
+ #
+ # Sub-directories that need to be built
+ #
+-subdirs       = external vpflib ogdi contrib
++subdirs       = vpflib ogdi contrib
+ #
+ # Default target to build everything in all sub-directories
+diff -urN a/ogdi/makefile b/ogdi/makefile
+--- a/ogdi/makefile
++++ b/ogdi/makefile
+@@ -15,7 +15,7 @@
+ #
+ # Sub-directories that need to be built
+ #
+-subdirs       = include c-api glutil attr_driver driver gltpd examples
++subdirs       = include c-api glutil attr_driver driver gltpd
+ #
+ # Default target to build everything in all sub-directories
diff --git a/sci-libs/ogdi/ogdi-4.1.0.ebuild b/sci-libs/ogdi/ogdi-4.1.0.ebuild
new file mode 100644 (file)
index 0000000..b51bd57
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Open Geographical Datastore Interface, a GIS support library"
+HOMEPAGE="http://ogdi.sourceforge.net/ https://github.com/libogdi/ogdi"
+SRC_URI="https://github.com/libogdi/ogdi/releases/download/${PN}_${PV//./_}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+       dev-libs/expat
+       net-libs/libtirpc:=
+       sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog NEWS README )
+
+PATCHES=(
+       "${FILESDIR}"/${P}-subdirs.patch
+       "${FILESDIR}"/${PN}-3.2.0-endianess.patch
+       "${FILESDIR}"/${PN}-3.2.0-optimisation.patch
+       "${FILESDIR}"/${PN}-3.2.0-tcl.patch
+)
+
+src_prepare() {
+       default
+       rm -r external || die
+       sed 's:O2:O9:g' -i configure || die
+}
+
+src_configure() {
+       export TOPDIR="${S}"
+       export TARGET=$(uname)
+       export CFG="release"
+       export LD_LIBRARY_PATH=$TOPDIR/bin/${TARGET}
+
+       econf \
+               --with-expat \
+               --with-zlib
+}
+
+src_compile() {
+       # bug #299239
+       emake -j1
+}
+
+src_install() {
+       mv "${S}"/bin/${TARGET}/*.so* "${S}"/lib/Linux/. || die "lib move failed"
+       dobin "${S}"/bin/${TARGET}/*
+       insinto /usr/include
+       doins ogdi/include/ecs.h ogdi/include/ecs_util.h
+       dolib.so lib/${TARGET}/lib*
+       einstalldocs
+}