dev-ros/urdf_tutorial: bump to 0.4.0
authorAlexis Ballier <aballier@gentoo.org>
Tue, 15 May 2018 06:20:13 +0000 (08:20 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 15 May 2018 06:20:13 +0000 (08:20 +0200)
Package-Manager: Portage-2.3.36, Repoman-2.3.9

dev-ros/urdf_tutorial/Manifest
dev-ros/urdf_tutorial/urdf_tutorial-0.4.0.ebuild [new file with mode: 0644]
dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild

index 4643a6c0e9318a8e068e874be9dfafd0f00952a5..5933b5e89fdeaa8e11a1386395655453d3a0d87c 100644 (file)
@@ -1 +1,2 @@
 DIST urdf_tutorial-0.3.0.tar.gz 871048 BLAKE2B 2bca4409696011c75e7b6c1ae811fe4caec3fe34b28ea80c9774b6068c64509a97452173c1e43ba92f77081419b58bf5f6987e1e9941eca8ce077c534636bad9 SHA512 1518cd2aa783e92dd7a996b9cff9df37f21f7585d59b6001bd9a42782b2a5d81e96e8d2502955283f29390c7fc4944250ff1d954ab6e511e0886f243c4aabbde
+DIST urdf_tutorial-0.4.0.tar.gz 865626 BLAKE2B 42a8c3274e00393f846d4e2e9641740dad214bbcdc4f65095f96f2faac1f3709170d5719085d5927ca0c322f9b8cc57b2f8494353bec629978874870a8d37206 SHA512 256859d83fb5860df27cf8922043fb61158134c1ea06f3943fed3b8183c7384819a761d83bcb03a924a813185be07e89ca510076bfa1dfe4c2e52f561503fa88
diff --git a/dev-ros/urdf_tutorial/urdf_tutorial-0.4.0.ebuild b/dev-ros/urdf_tutorial/urdf_tutorial-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..305da65
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/urdf_tutorial"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="URDF tutorials"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/urdf
+       dev-ros/joint_state_publisher
+       dev-ros/robot_state_publisher
+       dev-ros/rviz
+       dev-ros/xacro
+"
+DEPEND="${RDEPEND}
+       test? ( dev-ros/roslaunch[${PYTHON_USEDEP}] )
+"
index 5e71d27667090c51b6f1e2b9bc9380d90853ae9a..305da65fc71361ad56f0ce1e75053a1205a56c7c 100644 (file)
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 ROS_REPO_URI="https://github.com/ros/urdf_tutorial"
 KEYWORDS="~amd64"
-ROS_SUBDIR="${PN}"
 PYTHON_COMPAT=( python2_7 )
 
 inherit ros-catkin