dev-python/pilkit: Fix pillow USE-dep for tests
authorMichał Górny <mgorny@gentoo.org>
Tue, 19 May 2020 12:01:41 +0000 (14:01 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 19 May 2020 12:01:41 +0000 (14:01 +0200)
Closes: https://bugs.gentoo.org/723600
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pilkit/pilkit-2.0.ebuild

index dd16f29d4fb29b8a52cf49732ac243ffcfd2fbd3..6ef202af3c2cbf22cb97df3b22adbaf65eae0f7b 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
@@ -13,17 +13,13 @@ SRC_URI="https://github.com/matthewwithanm/${PN}/archive/${PV}.tar.gz -> ${P}.ta
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-CDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+BDEPEND="
        test? (
                dev-python/mock[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/pillow[${PYTHON_USEDEP},jpeg,zlib]
        )"
-RDEPEND="${CDEPEND}"
 
-python_test() {
-       nosetests --verbose || die
-}
+distutils_enable_tests nose