www-client/chromium: Fix build with clang
authorMike Gilbert <floppym@gentoo.org>
Tue, 29 Sep 2015 01:33:15 +0000 (21:33 -0400)
committerMike Gilbert <floppym@gentoo.org>
Tue, 29 Sep 2015 01:33:33 +0000 (21:33 -0400)
Only set host vars when cross-compiling.
This lets a native clang build work by default.

https://bugs.gentoo.org/561726

Package-Manager: portage-2.2.22_p3

www-client/chromium/chromium-45.0.2454.101.ebuild
www-client/chromium/chromium-46.0.2490.42.ebuild
www-client/chromium/chromium-47.0.2516.0.ebuild

index 15fbe60035bc4f7e8d603fb4235f26da4251291b..c450cda3ef1639940de37751e44ceebac5cca19b 100644 (file)
@@ -469,17 +469,19 @@ src_configure() {
        fi
 
        # Make sure the build system will use the right tools, bug #340795.
-       tc-export AR CC CXX RANLIB
+       tc-export AR CC CXX NM
 
        # Tools for building programs to be executed on the build system, bug #410883.
-       export AR_host=$(tc-getBUILD_AR)
-       export CC_host=$(tc-getBUILD_CC)
-       export CXX_host=$(tc-getBUILD_CXX)
-       export LD_host=${CXX_host}
+       if tc-is-cross-compiler; then
+               export AR_host=$(tc-getBUILD_AR)
+               export CC_host=$(tc-getBUILD_CC)
+               export CXX_host=$(tc-getBUILD_CXX)
+               export NM_host=$(tc-getBUILD_NM)
+       fi
 
        # Bug 491582.
        export TMPDIR="${WORKDIR}/temp"
-       mkdir -m 755 "${TMPDIR}" || die
+       mkdir -p -m 755 "${TMPDIR}" || die
 
        local build_ffmpeg_args=""
        if use pic && [[ "${ffmpeg_target_arch}" == "ia32" ]]; then
index 672ea96f1552d070052ccaa74b67a1503aa717ea..565c1f78e92d34096ead5143880d2c4e82877e1a 100644 (file)
@@ -469,17 +469,19 @@ src_configure() {
        fi
 
        # Make sure the build system will use the right tools, bug #340795.
-       tc-export AR CC CXX RANLIB
+       tc-export AR CC CXX NM
 
        # Tools for building programs to be executed on the build system, bug #410883.
-       export AR_host=$(tc-getBUILD_AR)
-       export CC_host=$(tc-getBUILD_CC)
-       export CXX_host=$(tc-getBUILD_CXX)
-       export LD_host=${CXX_host}
+       if tc-is-cross-compiler; then
+               export AR_host=$(tc-getBUILD_AR)
+               export CC_host=$(tc-getBUILD_CC)
+               export CXX_host=$(tc-getBUILD_CXX)
+               export NM_host=$(tc-getBUILD_NM)
+       fi
 
        # Bug 491582.
        export TMPDIR="${WORKDIR}/temp"
-       mkdir -m 755 "${TMPDIR}" || die
+       mkdir -p -m 755 "${TMPDIR}" || die
 
        local build_ffmpeg_args=""
        if use pic && [[ "${ffmpeg_target_arch}" == "ia32" ]]; then
index 50afc7c5af40b0d7078d8a929b9d91d318351e71..e8acf4a10d829217c34150d6936fd2508d1987bc 100644 (file)
@@ -477,17 +477,19 @@ src_configure() {
        fi
 
        # Make sure the build system will use the right tools, bug #340795.
-       tc-export AR CC CXX RANLIB
+       tc-export AR CC CXX NM
 
        # Tools for building programs to be executed on the build system, bug #410883.
-       export AR_host=$(tc-getBUILD_AR)
-       export CC_host=$(tc-getBUILD_CC)
-       export CXX_host=$(tc-getBUILD_CXX)
-       export LD_host=${CXX_host}
+       if tc-is-cross-compiler; then
+               export AR_host=$(tc-getBUILD_AR)
+               export CC_host=$(tc-getBUILD_CC)
+               export CXX_host=$(tc-getBUILD_CXX)
+               export NM_host=$(tc-getBUILD_NM)
+       fi
 
        # Bug 491582.
        export TMPDIR="${WORKDIR}/temp"
-       mkdir -m 755 "${TMPDIR}" || die
+       mkdir -p -m 755 "${TMPDIR}" || die
 
        local build_ffmpeg_args=""
        if use pic && [[ "${ffmpeg_target_arch}" == "ia32" ]]; then