dev-util/perf: use LLVM_MAX_SLOT=9 (bug 718644)
authorGuilherme Amadio <amadio@gentoo.org>
Fri, 24 Apr 2020 20:45:53 +0000 (22:45 +0200)
committerGuilherme Amadio <amadio@gentoo.org>
Fri, 24 Apr 2020 20:46:08 +0000 (22:46 +0200)
Closes: https://bugs.gentoo.org/718644
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
dev-util/perf/perf-5.6.4.ebuild

index ac50bdd498811aeb579ca1f39821d6cac02e0a18..3f1d4e665d10c5b216334919a270b52f0324ab3f 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python2_7 python3_{6,7} )
-inherit bash-completion-r1 estack eutils toolchain-funcs python-r1 linux-info
+inherit bash-completion-r1 estack eutils llvm toolchain-funcs python-r1 linux-info
 
 MY_PV="${PV/_/-}"
 MY_PV="${MY_PV/-pre/-git}"
@@ -42,8 +42,8 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 RDEPEND="audit? ( sys-process/audit )
        crypt? ( dev-libs/openssl:0= )
        clang? (
-               sys-devel/clang:*
-               sys-devel/llvm:*
+               <sys-devel/clang-10:*
+               <sys-devel/llvm-10:*
        )
        demangle? ( sys-libs/binutils-libs:= )
        gtk? ( x11-libs/gtk+:2 )
@@ -75,6 +75,10 @@ S="${S_K}/tools/perf"
 
 CONFIG_CHECK="~PERF_EVENTS ~KALLSYMS"
 
+pkg_setup() {
+       LLVM_MAX_SLOT=9 llvm_pkg_setup
+}
+
 src_unpack() {
        local paths=(
                tools/arch tools/build tools/include tools/lib tools/perf tools/scripts