Revert "app-crypt/dirmngr: tree clean"
authorAlon Bar-Lev <alonbl@gentoo.org>
Mon, 23 Jan 2017 18:17:43 +0000 (20:17 +0200)
committerAlon Bar-Lev <alonbl@gentoo.org>
Mon, 23 Jan 2017 18:17:57 +0000 (20:17 +0200)
This reverts commit 530dc0b7fb273174fb273f0fec93e1f5b2a26b77.

app-crypt/dirmngr/Manifest [new file with mode: 0644]
app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild [new file with mode: 0644]
app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch [new file with mode: 0644]
app-crypt/dirmngr/metadata.xml [new file with mode: 0644]

diff --git a/app-crypt/dirmngr/Manifest b/app-crypt/dirmngr/Manifest
new file mode 100644 (file)
index 0000000..6b6bad2
--- /dev/null
@@ -0,0 +1 @@
+DIST dirmngr-1.1.1.tar.bz2 566929 SHA256 d2280b8c314db80cdaf101211a47826734443436f5c3545cc1b614c50eaae6ff SHA512 922512f22853c49cf291207c81862c68ba51c89646036288592d6b2f57709d35ac53f9f550569986c04daec20403ab8ec85b08893443af417950916b869c8419 WHIRLPOOL 84a174d42418723e346c7af8d9bb9aa12e4602cbba9510f492ef10d29f4900768ede986d2c7c93cee129ce03e5aeca08357490ec050b54e1250e2e4b36150617
diff --git a/app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild b/app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..d9c8bd8
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="DirMngr is a daemon to handle CRL and certificate requests for GnuPG"
+HOMEPAGE="http://www.gnupg.org/download/index.en.html#dirmngr"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 sparc x86"
+IUSE="nls"
+
+RDEPEND=">=net-nds/openldap-2.1.26
+       >=dev-libs/libgpg-error-1.4
+       >=dev-libs/libgcrypt-1.4.0:0
+       >=dev-libs/libksba-1.0.2
+       >=dev-libs/pth-1.3.7
+       nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+       >=dev-libs/libassuan-2
+       nls? ( >=sys-devel/gettext-0.12.1 )"
+
+src_prepare() {
+       epatch "${FILESDIR}/${P}-pth.patch"
+}
+
+src_configure() {
+       econf --docdir="/usr/share/doc/${PF}" $(use_enable nls) \
+               LDAPLIBS="-lldap -llber"
+}
+
+src_install() {
+       default
+       dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
diff --git a/app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch b/app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch
new file mode 100644 (file)
index 0000000..862458e
--- /dev/null
@@ -0,0 +1,17 @@
+Index: src/dirmngr.c
+===================================================================
+--- src/dirmngr.c      (revision 348)
++++ src/dirmngr.c      (working copy)
+@@ -665,8 +665,11 @@
+      the option parsing may need services of the libraries. */
+   /* Libgcrypt requires us to register the threading model first.
+-     Note that this will also do the pth_init. */
++     Note that this will also do the pth_init for libgcrypt < 1.6 */
++#if GCRYPT_VERSION_NUMBER >= 0x010600
++  pth_init ();
++#endif
+   /* Init Libgcrypt. */
+   rc = gcry_control (GCRYCTL_SET_THREAD_CBS, &gcry_threads_pth);
+   if (rc)
diff --git a/app-crypt/dirmngr/metadata.xml b/app-crypt/dirmngr/metadata.xml
new file mode 100644 (file)
index 0000000..f1c3d59
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>crypto@gentoo.org</email>
+       <name>Crypto</name>
+</maintainer>
+</pkgmetadata>