Include look&feel settings in the .jar file again, this time unpack them from bundled...
authorVlastimil Babka <caster@gentoo.org>
Tue, 16 Jan 2007 16:20:37 +0000 (16:20 +0000)
committerVlastimil Babka <caster@gentoo.org>
Tue, 16 Jan 2007 16:20:37 +0000 (16:20 +0000)
Package-Manager: portage-2.1.2

dev-java/jgoodies-looks/ChangeLog
dev-java/jgoodies-looks/files/digest-jgoodies-looks-2.0.4-r2 [new file with mode: 0644]
dev-java/jgoodies-looks/jgoodies-looks-2.0.4-r1.ebuild
dev-java/jgoodies-looks/jgoodies-looks-2.0.4-r2.ebuild [new file with mode: 0644]

index 1d42df6b223df7e14588b2da7b7b46ba0e106f60..4cd1beae0ac90a7b52e31f9d678d169f5d69883f 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for dev-java/jgoodies-looks
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-looks/ChangeLog,v 1.24 2007/01/16 15:47:31 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-looks/ChangeLog,v 1.25 2007/01/16 16:20:36 caster Exp $
+
+*jgoodies-looks-2.0.4-r2 (16 Jan 2007)
+
+  16 Jan 2007; Vlastimil Babka <caster@gentoo.org> -files/plastic-2.0.4.txt,
+  jgoodies-looks-2.0.4-r1.ebuild, +jgoodies-looks-2.0.4-r2.ebuild:
+  Include look&feel settings in the .jar file again, this time unpack them
+  from bundled .jar before deleting, instead of FILESDIR, because they are not
+  part of source files for some reason. Don't filter ecj-3.1 which was by
+  mistake.
 
   16 Jan 2007; Vlastimil Babka <caster@gentoo.org>
   -files/1.3_beta1-build.xml, -files/plastic-1.3.1.txt,
diff --git a/dev-java/jgoodies-looks/files/digest-jgoodies-looks-2.0.4-r2 b/dev-java/jgoodies-looks/files/digest-jgoodies-looks-2.0.4-r2
new file mode 100644 (file)
index 0000000..b33c5f7
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 d4a4c1cc7f334a592d42b303a72528a8 looks-2_0_4.zip 1952358
+RMD160 730242eeb54cc4bbf89809ae1bdec3f2cbe05c00 looks-2_0_4.zip 1952358
+SHA256 203cfd1f12f0e5e0b901a145f91701106adad1131694823f0104b54b4ed0c619 looks-2_0_4.zip 1952358
index 8851e53690ebc21b87c6e979ccd346af3e5480f4..826254b80cb6b90d11e98dc87bd552ed85f9354c 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-looks/jgoodies-looks-2.0.4-r1.ebuild,v 1.5 2007/01/15 12:19:26 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-looks/jgoodies-looks-2.0.4-r1.ebuild,v 1.6 2007/01/16 16:20:36 caster Exp $
 
 inherit eutils java-pkg-2 java-ant-2
 
@@ -35,7 +35,7 @@ src_unpack() {
 
 src_compile() {
        # bug #150970
-       java-pkg_filter-compiler jikes ecj-3.1
+       java-pkg_filter-compiler jikes
 
        # jar target fails unless we make descriptors.dir an existing directory
        # I checked the ustream binary distribution and they also don't actually
diff --git a/dev-java/jgoodies-looks/jgoodies-looks-2.0.4-r2.ebuild b/dev-java/jgoodies-looks/jgoodies-looks-2.0.4-r2.ebuild
new file mode 100644 (file)
index 0000000..57de2a9
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-looks/jgoodies-looks-2.0.4-r2.ebuild,v 1.1 2007/01/16 16:20:36 caster Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_V="${PV//./_}"
+DESCRIPTION="JGoodies Looks Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/looks-${MY_V}.zip"
+
+LICENSE="BSD"
+SLOT="2.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc source"
+
+DEPEND=">=virtual/jdk-1.4
+       dev-java/ant-core
+       app-arch/unzip
+       source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/looks-${PV}"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       # remove the bootclasspath brokedness, make building demo optional
+       epatch "${FILESDIR}/${P}-build.xml.patch"
+
+       # unzip the look&feel settings from bundled jar before we delete it
+       unzip -j looks-${PV}.jar META-INF/services/javax.swing.LookAndFeel \
+               || die "unzip of javax.swing.LookAndFeel failed"
+       # and rename it to what build.xml expects
+       mv javax.swing.LookAndFeel all.txt
+
+       rm -v *.jar demo/*.jar lib/*.jar
+       rm -rf docs/api
+}
+
+src_compile() {
+       # bug #150970
+       java-pkg_filter-compiler jikes
+
+       # jar target fails unless we make descriptors.dir an existing directory
+       # I checked the ustream binary distribution and they also don't actually
+       # put anything there.
+       # 31.7.2006 betelgeuse@gentoo.org
+       # update: it's where it looks for all.txt file
+       # 16.1.2007 caster@gentoo.org
+       eant -Ddescriptors.dir="${S}" jar-all $(use_doc)
+}
+
+src_install() {
+       java-pkg_dojar build/looks.jar
+
+       dodoc RELEASE-NOTES.txt
+       dohtml README.html
+       if use doc; then
+               java-pkg_dohtml -r docs/*
+               java-pkg_dojavadoc build/docs/api
+       fi
+       use source && java-pkg_dosrc src/core/com
+}