Remove obsolete version. Add postinst warning about cgi-bin ownership. Fix configurat...
authorAlin Năstac <mrness@gentoo.org>
Tue, 19 Dec 2006 09:50:44 +0000 (09:50 +0000)
committerAlin Năstac <mrness@gentoo.org>
Tue, 19 Dec 2006 09:50:44 +0000 (09:50 +0000)
Package-Manager: portage-2.1.1-r2

www-apps/dspam-web/ChangeLog
www-apps/dspam-web/dspam-web-3.6.8-r1.ebuild [new file with mode: 0644]
www-apps/dspam-web/files/digest-dspam-web-3.6.8-r1 [new file with mode: 0644]
www-apps/dspam-web/files/postinst-en.txt

index 563727130eab2ea15c6b97fc7c5d6723db0baa02..aeed1108b005432732dcb8a357c60e284974220a 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for www-apps/dspam-web
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.26 2006/11/23 16:36:21 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.27 2006/12/19 09:50:44 mrness Exp $
+
+*dspam-web-3.6.8-r1 (19 Dec 2006)
+
+  19 Dec 2006; Alin Năstac <mrness@gentoo.org> files/postinst-en.txt,
+  -dspam-web-3.6.4.ebuild, -dspam-web-3.6.8.ebuild,
+  +dspam-web-3.6.8-r1.ebuild:
+  Remove obsolete version. Add postinst warning about cgi-bin ownership. Fix
+  configuration autodetection in cgi scripts.
 
   23 Nov 2006; Francesco Riosa <vivo@gentoo.org> dspam-web-3.6.4.ebuild:
   dev-db/mysql => virtual/mysql
diff --git a/www-apps/dspam-web/dspam-web-3.6.8-r1.ebuild b/www-apps/dspam-web/dspam-web-3.6.8-r1.ebuild
new file mode 100644 (file)
index 0000000..cecbd0c
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.6.8-r1.ebuild,v 1.1 2006/12/19 09:50:44 mrness Exp $
+
+inherit webapp eutils autotools
+
+DESCRIPTION="Web based administration and user controls for dspam"
+HOMEPAGE="http://dspam.nuclearelephant.com/"
+SRC_URI="http://dspam.nuclearelephant.com/sources/dspam-${PV}.tar.gz
+       mirror://gentoo/dspam-${PV}-patches-20061219.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=mail-filter/dspam-${PV}"
+RDEPEND="${DEPEND}
+       >=dev-perl/GD-2.0
+       dev-perl/GD-Graph3d
+       dev-perl/GDGraph
+       dev-perl/GDTextUtil"
+
+# some FHS-like structure
+HOMEDIR="/var/spool/dspam"
+CONFDIR="/etc/mail/dspam"
+
+S="${WORKDIR}/dspam-${PV}"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       EPATCH_SUFFIX="patch"
+       epatch "${WORKDIR}"/patches
+
+       AT_M4DIR="${S}/m4"
+       eautoreconf
+}
+
+src_compile() {
+       econf \
+                       --with-dspam-home=${HOMEDIR} \
+                       --sysconfdir=${CONFDIR}  || die "econf failed"
+       cd "${S}/webui"
+       emake || die "emake failed"
+}
+
+src_install() {
+       webapp_src_preinst
+
+       cd "${S}/webui"
+       insinto "${MY_HTDOCSDIR}"
+       insopts -m644
+       doins htdocs/*.{css,gif}
+       insinto "${MY_CGIBINDIR}/templates"
+       doins cgi-bin/templates/*.html
+       insinto "${MY_CGIBINDIR}"
+       doins cgi-bin/{admins,configure.pl,default.prefs,rgb.txt,*.cgi}
+
+       webapp_configfile "${MY_CGIBINDIR}"/{admins,configure.pl,default.prefs,rgb.txt}
+
+       webapp_hook_script "${FILESDIR}/setperms"
+       webapp_postinst_txt en "${FILESDIR}/postinst-en.txt"
+
+       webapp_src_install
+}
+
+pkg_postinst() {
+       ewarn "If you're using apache dspam-web's config requires the scripts in the cgi-bin"
+       ewarn "to be run as dspam:dspam. You will have to put a global SuexecUserGroup"
+       ewarn "declaration in the main server config which will force everything in cgi-bin"
+       ewarn "to run as dspam:dspam."
+       ewarn "You should use a dedicated virtual host for this application or at least"
+       ewarn "one that don't have any other cgi scripts."
+       echo
+       webapp_pkg_postinst
+}
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.6.8-r1 b/www-apps/dspam-web/files/digest-dspam-web-3.6.8-r1
new file mode 100644 (file)
index 0000000..bd9d4c6
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 8963eddd665c06dc2ab666e2a61f50e6 dspam-3.6.8-patches-20061219.tar.gz 5370
+RMD160 0347a618b63b9fe662838f888f84b705bd24c72a dspam-3.6.8-patches-20061219.tar.gz 5370
+SHA256 cdd43862d939e089052bf0fde9e85f7a6b056a441d2d54ff4f3b8bb016f0de4c dspam-3.6.8-patches-20061219.tar.gz 5370
+MD5 c4b1a7079690ee16d8b0f36b2a2a90a4 dspam-3.6.8.tar.gz 743275
+RMD160 93a70db14070cb61bd2ef1b0ca55a18be1dbfd7b dspam-3.6.8.tar.gz 743275
+SHA256 88c7b41fb81e90ba8a260885a1d14bce39f2ef4a06cc2c6b8bfa0b99ba1aec34 dspam-3.6.8.tar.gz 743275
index 490fa75866d34bf9eafae875a8b530684fed25a8..500f5002abc2dee4e0701becc69682bdd2ee5af7 100644 (file)
@@ -8,7 +8,7 @@ Define your virtual host like this:
        RewriteRule ^/?$ /cgi-bin/dspam.cgi [redirect,last]
        
        SuexecUserGroup dspam dspam
-       ScriptAlias /cgi-bin/ ${VHOST_CGIBINDIR}
+       ScriptAlias /cgi-bin/ ${VHOST_CGIBINDIR}/
 
        <Directory "${VHOST_CGIBINDIR}">
                Options FollowSymLinks ExecCGI
@@ -16,7 +16,7 @@ Define your virtual host like this:
 
                AllowOverride None
                Order deny,allow
-               Deny from all
+               Allow from all
 
                AuthType basic
                AuthName "DSPAM Control Center"