dev-ros/nodelet_topic_tools: Set PYTHON_COMPAT and add missing usedep on dynamic_reco...
authorAlexis Ballier <aballier@gentoo.org>
Mon, 28 Sep 2015 12:44:33 +0000 (14:44 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 28 Sep 2015 12:44:45 +0000 (14:44 +0200)
Package-Manager: portage-2.2.22

dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.3-r1.ebuild [new file with mode: 0644]
dev-ros/nodelet_topic_tools/nodelet_topic_tools-9999.ebuild

diff --git a/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.3-r1.ebuild b/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.3-r1.ebuild
new file mode 100644 (file)
index 0000000..9051d41
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Common nodelet tools such as a mux, demux and throttle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=[threads]
+       dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+       dev-ros/message_filters
+       dev-ros/nodelet
+       dev-ros/pluginlib
+       dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"
index 444b0acee84210763f82898f3dc4d1b01754d8d7..9051d411fb0c69495d8f345790e9b9672d263c23 100644 (file)
@@ -6,6 +6,7 @@ EAPI=5
 ROS_REPO_URI="https://github.com/ros/nodelet_core"
 KEYWORDS="~amd64 ~arm"
 ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
 
 inherit ros-catkin
 
@@ -16,7 +17,7 @@ IUSE=""
 
 RDEPEND="
        dev-libs/boost:=[threads]
-       dev-ros/dynamic_reconfigure
+       dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
        dev-ros/message_filters
        dev-ros/nodelet
        dev-ros/pluginlib