app-vim/jedi: switch 0.10.0 to python-single-r1 instead
authorJoonas Niilola <juippis@gentoo.org>
Sun, 26 Apr 2020 08:12:07 +0000 (11:12 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 26 Apr 2020 08:39:52 +0000 (11:39 +0300)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-vim/jedi/jedi-0.10.0.ebuild

index 3c05067b9c6966d70a97c7fee90bfd38d1323d96..b30e03db8527cc230749106b7675a0f26ece24ce 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit vim-plugin python-any-r1
+inherit vim-plugin python-single-r1
 
 DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
 HOMEPAGE="https://github.com/davidhalter/jedi-vim"
@@ -15,9 +15,11 @@ LICENSE="MIT"
 KEYWORDS="~amd64 ~x86"
 IUSE="test"
 
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
 RDEPEND="
        ${PYTHON_DEPS}
-       $(python_gen_any_dep 'dev-python/jedi[${PYTHON_USEDEP}]')
+       $(python_gen_cond_dep 'dev-python/jedi[${PYTHON_MULTI_USEDEP}]')
        app-editors/vim[python]"
 BDEPEND="${PYTHON_DEPS}
        test? ( dev-python/pytest )"