x11-wm/afterstep: Bump to version 2.2.12
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 6 Sep 2015 16:37:16 +0000 (18:37 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 6 Sep 2015 16:37:34 +0000 (18:37 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
x11-wm/afterstep/Manifest
x11-wm/afterstep/afterstep-2.2.12.ebuild [new file with mode: 0644]

index a133cbb0c6213a9e105de84da5b34369ee0bec2c..eb97e36b0ca0e88da11f0c721fd3ef08f2b2b629 100644 (file)
@@ -1,2 +1,3 @@
 DIST AfterStep-2.2.11.tar.bz2 6126237 SHA256 ca7e872fc4d8320899667087d934e0672a3f38264a5207ea314d3c20242903aa SHA512 cf6663427656162f20cce596f63c7368c66fb336d5865dda5127f5aae123c61d647444336cc4c339ae6c64e5f25e837c0ba8889d30b1298ef26569505e0ff3d9 WHIRLPOOL 057d2420776be19db7ddf69ca7a7a2dae570dcca3b9fad4e56e8c9b4268d1f6c5dc6cbcc45b6caab41b3c06dcf7efe2b06289cf2684ac22a3dc2879282ff898f
+DIST AfterStep-2.2.12.tar.bz2 6132233 SHA256 ff15da51d4122b8e0286567052951e11a746e7d878dade9ce37f9217439ffbc8 SHA512 5cac6ce74b24cbcc5b8e8a6f7cc9308e110f0d09597af1fa0a8730d5f5111932a23332629bc4d372fc8d9583a514d97e35f747b17decf8d4ebfe5e3f20cdbbee WHIRLPOOL eca804facc37252ebd8e3b8d02f23b6fc66f8a8895337bcfd5cbd1f88f4e09868d0e2005a8be29be785b1259914bca132da7ac63f584964e535c3108a0182028
 DIST AfterStep-2.2.9.tar.bz2 6094706 SHA256 678493cd3ec44eee219d65fee0e612f2d1e36f8b93cbabdf40a22133c0617148
diff --git a/x11-wm/afterstep/afterstep-2.2.12.ebuild b/x11-wm/afterstep/afterstep-2.2.12.ebuild
new file mode 100644 (file)
index 0000000..20ebf4c
--- /dev/null
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A feature rich NeXTish window manager"
+HOMEPAGE="http://www.afterstep.org/"
+SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2
+       mirror://sourceforge/${PN}/AfterStep-${PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug dbus gif gtk jpeg cpu_flags_x86_mmx nls png svg tiff xinerama"
+
+RDEPEND="media-libs/freetype
+       alsa? ( media-libs/alsa-lib )
+       dbus? ( sys-apps/dbus )
+       jpeg? ( virtual/jpeg:= )
+       gif? ( >=media-libs/giflib-4.1.0 )
+       gtk? ( x11-libs/gtk+:2 )
+       png? ( media-libs/libpng:0= )
+       svg? ( gnome-base/librsvg:2 )
+       tiff? ( media-libs/tiff:0 )
+       x11-libs/libICE
+       x11-libs/libXext
+       x11-libs/libSM
+       x11-libs/libXmu
+       x11-libs/libXt
+       x11-libs/libX11
+       x11-libs/libXpm
+       x11-libs/libXrender
+       xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+       !!media-libs/libafterimage
+       x11-proto/xextproto
+       x11-proto/xproto
+       xinerama? ( x11-proto/xineramaproto )"
+
+S=${WORKDIR}/${PN}-devel-${PV}
+
+src_prepare() {
+       sed -i -e '/^install:/s:install.alternative ::' Makefile.in || die
+       sed -i -e '/CFLAGS="-O3"/d' libAfter{Base,Image}/configure || die
+       sed -i -e '/STRIP_BINARIES/s:-s::' autoconf/configure.in || die #252119
+       sed -i -e '/--with-builtin-gif/s/$with_gif/no/' autoconf/configure.in || die #253259
+
+       pushd autoconf >/dev/null
+       eautoreconf
+       cp autoconf/config.h.in ./ || die
+       cp configure ../ || die
+       popd >/dev/null
+
+       pushd libAfterBase >/dev/null
+       eautoreconf
+       popd >/dev/null
+}
+
+src_configure() {
+       local myconf
+
+       use debug && myconf="--enable-gdb --enable-warn --enable-gprof
+               --enable-audit --enable-trace --enable-trace-x"
+
+       # Explanation of configure options
+       # ================================
+       # --with-helpcommand="xterm -e man" -  Avoid installing xiterm
+       # --with-xpm - Contained in xfree
+       # --disable-availability - So we can use complete paths for menuitems
+       # --enable-ascp - The AfterStep ControlPanel is abandoned
+       # LDCONFIG - bug #265841
+
+       LDCONFIG=/bin/true econf \
+               $(use_enable alsa) \
+               $(use_enable cpu_flags_x86_mmx mmx-optimization) \
+               $(use_enable nls i18n) \
+               $(use_enable xinerama) \
+               $(use_with dbus dbus1) \
+               $(use_with gif) \
+               $(use_with gtk) \
+               $(use_with jpeg) \
+               $(use_with png) \
+               $(use_with tiff) \
+               $(use_with svg) \
+               --with-helpcommand="xterm -e man" \
+               --disable-availability \
+               --disable-staticlibs \
+               --enable-ascp=no \
+               ${myconf}
+}
+
+src_compile() {
+       # gcc: ../libAfterConf/libAfterConf.a: No such file or directory
+       # make[1]: *** [PrintDesktopEntries] Error 1
+       emake -j1
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+
+       # Create a symlink from MonitorWharf to Wharf
+       rm "${D}"/usr/bin/MonitorWharf
+       dosym /usr/bin/Wharf /usr/bin/MonitorWharf
+
+       # Handle the documentation
+       dodoc ChangeLog INSTALL NEW* README* TEAM
+       cp -pPR TODO "${D}"/usr/share/doc/${PF}/
+       dodir /usr/share/doc/${PF}/html
+       cp -pPR doc/* "${D}"/usr/share/doc/${PF}/html
+       rm "${D}"/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
+
+       insinto /usr/share/xsessions
+       newins AfterStep.desktop.final AfterStep.desktop
+
+       # For desktop managers like GDM or KDE
+       exeinto /etc/X11/Sessions
+       doexe "${FILESDIR}"/${PN}
+}