sys-apps/ibm-powerpc-utils: Version 1.3.6
authorJeroen Roovers <jer@gentoo.org>
Thu, 6 Jun 2019 09:41:38 +0000 (11:41 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 6 Jun 2019 09:44:04 +0000 (11:44 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
sys-apps/ibm-powerpc-utils/Manifest
sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.6.ebuild [new file with mode: 0644]

index 080407dbcea9faf317dcc99e5983687c517a507f..458a8ff74cf1f187c6d74d6054ba7c280ecde8d8 100644 (file)
@@ -1 +1,2 @@
 DIST ibm-powerpc-utils-1.3.5.tar.gz 318046 BLAKE2B cb154dd6203aea2f95c8cce96e3ea5f40c0c4d9f8c649c988d0d66adfc475bb15764554160faeeebddd5569de39502c149bf93f08fa433e8e309498fff59cae1 SHA512 a01f8fc45abd91d0629f8f48e3c2877a863aa1f244907bb65fcc457c2c933e7043181666c237956723f956b7c3d7ce7a0cedc36eaf26ce3cf777aa8f0525244d
+DIST ibm-powerpc-utils-1.3.6.tar.gz 320582 BLAKE2B cce656ca7eefda3912f26c6df99112ceef831cac834af4edaf507c28c63d6bbca0d6ae0dd096474b7d3ac45daffb37dbc1068cb33b83f676922e4f27ca46ae2e SHA512 a30516ccdfe19a198cd5c1a7ad3646d15b599fb40f772cbc7ac95c6d3b364575a3ebb16708022886ba3bcd3184070a3f4d72b649427879fcdd2655406470e977
diff --git a/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.6.ebuild b/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.6.ebuild
new file mode 100644 (file)
index 0000000..a7cd329
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Utilities for the maintainance of the IBM and Apple PowerPC platforms"
+HOMEPAGE="https://github.com/ibm-power-utilities/powerpc-utils"
+SRC_URI="https://github.com/ibm-power-utilities/${PN//ibm-}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="+rtas"
+
+S="${WORKDIR}/${P//ibm-}"
+
+SLOT="0"
+LICENSE="IBM"
+KEYWORDS="~ppc ~ppc64"
+
+DEPEND="
+       sys-devel/bc
+"
+RDEPEND="
+       ${DEPEND}
+       !sys-apps/powerpc-utils
+       rtas? ( >=sys-libs/librtas-2.0.2 )
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.3.5-docdir.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf $(use_with rtas librtas)
+}