app-office/moneyguru: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 11:28:52 +0000 (12:28 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:10:57 +0000 (17:10 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-office/moneyguru/moneyguru-2.13.1-r2.ebuild [moved from app-office/moneyguru/moneyguru-2.13.1-r1.ebuild with 83% similarity]
app-office/moneyguru/moneyguru-3.0.1-r2.ebuild [moved from app-office/moneyguru/moneyguru-3.0.1-r1.ebuild with 84% similarity]

similarity index 83%
rename from app-office/moneyguru/moneyguru-2.13.1-r1.ebuild
rename to app-office/moneyguru/moneyguru-2.13.1-r2.ebuild
index 5e3aaab58e123f873ea667107570ad6fab7b653c..31987d2240e4f6643633dcad8ee36892b35cebf3 100644 (file)
@@ -21,11 +21,15 @@ REQUIRED_USE=${PYTHON_REQUIRED_USE}
 RDEPEND="${PYTHON_DEPS}
        dev-db/sqlite:3
        dev-libs/glib:2
-       dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,printsupport]
+       $(python_gen_cond_dep '
+               dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,widgets,printsupport]
+       ')
        dev-qt/qttranslations"
 DEPEND="${RDEPEND}
        test? (
-               <dev-python/pytest-4[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '
+                       <dev-python/pytest-4[${PYTHON_MULTI_USEDEP}]
+               ')
                dev-util/cunit
        )"
 
similarity index 84%
rename from app-office/moneyguru/moneyguru-3.0.1-r1.ebuild
rename to app-office/moneyguru/moneyguru-3.0.1-r2.ebuild
index db78b348715e051df38f6078a7edbf23bcd6c2d7..ba927b91e60b95e6f2f336b11dab2604e2776aad 100644 (file)
@@ -21,11 +21,15 @@ REQUIRED_USE=${PYTHON_REQUIRED_USE}
 RDEPEND="${PYTHON_DEPS}
        dev-db/sqlite:3
        dev-libs/glib:2
-       dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,printsupport]
+       $(python_gen_cond_dep '
+               dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,widgets,printsupport]
+       ')
        dev-qt/qttranslations"
 DEPEND="${RDEPEND}
        test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '
+                       dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+               ')
                dev-util/cunit
        )"