dev-python/editobj: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:13 +0000 (10:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:13 +0000 (10:56 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/editobj/editobj-0.5.7-r2.ebuild

index 631be827e83bc17aeaa84c6e32354da3f2094880..aab2f6b390d6b236384da074b2d4c497ea94559d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -24,6 +24,11 @@ RDEPEND=""
 S="${WORKDIR}/${MY_P}"
 
 python_install_all() {
-       use examples && local EXAMPLES=( demo/. )
+       if use examples; then
+               docinto examples
+               dodoc -r demo/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
        distutils-r1_python_install_all
 }