dev-ruby/curb: add 0.9.10
authorHans de Graaff <graaff@gentoo.org>
Sat, 20 Apr 2019 06:08:43 +0000 (08:08 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 20 Apr 2019 06:36:30 +0000 (08:36 +0200)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-ruby/curb/Manifest
dev-ruby/curb/curb-0.9.10.ebuild [new file with mode: 0644]

index 23df56deb4c0e60278b17d038f9b14f9f3ade653..6e0f4f837a0c4d72cfbd98a433ee9bfddd923bb1 100644 (file)
@@ -1 +1,2 @@
+DIST curb-0.9.10.gem 88064 BLAKE2B 8f761e752bc1fd0775f012373847330d3ced9d394e5159b74c8e329247f6221bbc26978755d84b91e75b4082b7bb50c7755db299f90f291516f355b4ab1ddc7c SHA512 eab82d3c1b34bf8e5bfd334abca38a80eaab255d31164ca189185b8b98d7f3760fb116babf50dce5aef01be30b15e9374e7a84e1b0926dba13c3e9f8d36c54ca
 DIST curb-0.9.9.gem 87040 BLAKE2B 107c6486887c0c168a06b7cdad4cc01e34a85c7cfb20e8991db4c695e9dfe3700655d95dbc798e4eb3269586b86d61037d0e39a88c4d687e0e776a0e9cc27f0e SHA512 3f91004e109f9cc7c2d58fb7a6bc387d037237442b05ee52bad2944738eb24bf8d909ad7c21db965ba1e6291d08f0f2335c54a5c1a1ee1d224c5790e81dc8037
diff --git a/dev-ruby/curb/curb-0.9.10.ebuild b/dev-ruby/curb/curb-0.9.10.ebuild
new file mode 100644 (file)
index 0000000..37839c5
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby-language bindings for libcurl"
+HOMEPAGE="https://github.com/taf2/curb"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" net-misc/curl[ssl]"
+RDEPEND+=" net-misc/curl[ssl]"
+
+all_ruby_prepare() {
+       # fix tests when localhost is also ::1
+       sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
+
+       # avoid tests making outside network connections
+       rm tests/bug_postfields_crash.rb || die
+       sed -e '/test_easy_http_verbs_must_respond_to_str/,/^  end/ s:^:#:' \
+               -i tests/tc_curl_easy.rb || die
+       sed -e '/test_connection_keepalive/aomit "network connection needed"' \
+               -i tests/tc_curl_multi.rb || die
+
+       # avoid failing tests where failure condition seems weird, no
+       # upstream travis so not clear if the test is indeed broken.
+       sed -i -e '/test_multi_easy_http/,/^  end/ s:^:#:' tests/tc_curl_multi.rb || die
+}
+
+each_ruby_configure() {
+       ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+       emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
+       cp -l ext/curb_core$(get_modname) lib || die
+}