net-misc/memcached: Bump 1.6.x release (security fix)
authorSam James (sam_c) <sam@cmpct.info>
Mon, 23 Mar 2020 17:57:38 +0000 (17:57 +0000)
committerRobin H. Johnson <robbat2@gentoo.org>
Mon, 23 Mar 2020 19:26:19 +0000 (12:26 -0700)
Only affects 1.6.0, 1.6.1.

Bug: https://bugs.gentoo.org/714068
Closes: https://github.com/gentoo/gentoo/pull/15072
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
net-misc/memcached/Manifest
net-misc/memcached/memcached-1.6.2.ebuild [new file with mode: 0644]

index d8b1dc50a85a6998984b4ab72329a14b41ea46c7..0f16ffa8c7eef250583eca41b4883fce58721422 100644 (file)
@@ -2,3 +2,4 @@ DIST memcached-1.5.14.tar.gz 485076 BLAKE2B 729b4b708e921184bfedadbb02b0304eb09d
 DIST memcached-1.5.22.tar.gz 532713 BLAKE2B 90787522f36d9d4389438334572725df18050ae67bda2d97cde67b01492ca81772ddf7e83e02f71031ca909402a68f3db085ef6bece6e032ce580676a8a722f3 SHA512 19804c2847679eb018a0221b0717ebbcd2cd33b7f03176cc0d77b7405152dc944d3f5c39d0d81fcb6c08a2fa9317959e25587e7cb50718fdb6675288b2b078aa
 DIST memcached-1.6.0.tar.gz 534708 BLAKE2B 91b76c6cb6b75b851cafb7a74d7bdc2243f9d8642756dbb927914c2ba3de83c85142a39d64002aaec7125dc5ce096aca3fa7b639e6e5bc0eaacc7f4c756acd0d SHA512 e20dfab3ebfda97f94696ffedd98f8048bf101ed184f4e8925841bfadfe486d56848ab4eea68f3265baba6588ff7ec6b50664b1e9b7bda1c5b2c379481448b85
 DIST memcached-1.6.1.tar.gz 536518 BLAKE2B bd91855a6e624acb8d5fb9ea4a1f1c54a7b7516bf2334cb83448c0681cb6aa18f6a8a92f3361fd6da76fc3fa7ab311c8a9e38830a2d5fd47162e03236f026f2b SHA512 1010486284026331a11c600ea524cf6e76266261d38a515bce00ff057984fd993983c38118356d4b447b83fac7d5938bdc8b2e818d29f3dc3ab6a821694bb5ad
+DIST memcached-1.6.2.tar.gz 536527 BLAKE2B e350ee10ed74d68206baa009fa49e30e6563a21fd617fc30c1c2695642f6a5f85662acc40471d903a54c26153ca904d1ce9fb3bcbc7bae5d06431069872ca812 SHA512 e695c1292fc85280be3d337990c37f6fcf85e1a73870d541b993335b12f33b31516b477c30169a40c7b5d24fac8c842fdc5f1f48348c5cafa593040229349640
diff --git a/net-misc/memcached/memcached-1.6.2.ebuild b/net-misc/memcached/memcached-1.6.2.ebuild
new file mode 100644 (file)
index 0000000..f5940b4
--- /dev/null
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils flag-o-matic systemd
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="High-performance, distributed memory object caching system"
+HOMEPAGE="http://memcached.org/"
+SRC_URI="https://www.memcached.org/files/${MY_P}.tar.gz
+       https://www.memcached.org/files/old/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug sasl seccomp selinux slabs-reassign test" # hugetlbfs later
+
+RDEPEND=">=dev-libs/libevent-1.4:=
+       dev-lang/perl
+       sasl? ( dev-libs/cyrus-sasl )
+       seccomp? ( sys-libs/libseccomp )
+       selinux? ( sec-policy/selinux-memcached )"
+DEPEND="${RDEPEND}
+       acct-user/memcached
+       test? ( virtual/perl-Test-Harness >=dev-perl/Cache-Memcached-1.24 )"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.2.2-fbsd.patch"
+       "${FILESDIR}/${PN}-1.4.0-fix-as-needed-linking.patch"
+       "${FILESDIR}/${PN}-1.4.4-as-needed.patch"
+       "${FILESDIR}/${PN}-1.4.17-EWOULDBLOCK.patch"
+)
+
+src_prepare() {
+       sed -i -e 's,-Werror,,g' configure.ac || die
+       sed -i -e 's,AM_CONFIG_HEADER,AC_CONFIG_HEADERS,' configure.ac || die
+       eautoreconf
+       use slabs-reassign && append-flags -DALLOW_SLABS_REASSIGN
+
+       # Tweak upstream systemd unit to use Gentoo variables/envfile.
+       # As noted by bug #587440
+       sed -i -e '/^ExecStart/{
+                       s,{USER},{MEMCACHED_RUNAS},g;
+                       s,{CACHESIZE},{MEMUSAGE},g;
+                       s,OPTIONS,MISC_OPTS,g;
+               };
+               /Environment=/{s,OPTIONS,MISC_OPTS,g;};
+               /EnvironmentFile=/{s,/sysconfig/,/conf.d/,g;};
+               ' \
+               "${S}"/scripts/memcached.service
+       default
+}
+
+src_configure() {
+       econf \
+               --disable-docs \
+               $(use_enable sasl)
+       # The xml2rfc tool to build the additional docs requires TCL :-(
+       # `use_enable doc docs`
+}
+
+src_compile() {
+       # There is a heavy degree of per-object compile flags
+       # Users do NOT know better than upstream. Trying to compile the testapp and
+       # the -debug version with -DNDEBUG _WILL_ fail.
+       append-flags -UNDEBUG -pthread
+       emake testapp memcached-debug CFLAGS="${CFLAGS}"
+       filter-flags -UNDEBUG
+       emake
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       dobin scripts/memcached-tool
+       use debug && dobin memcached-debug
+
+       dodoc AUTHORS ChangeLog NEWS README.md doc/{CONTRIBUTORS,*.txt}
+
+       newconfd "${FILESDIR}/memcached.confd" memcached
+       newinitd "${FILESDIR}/memcached.init2" memcached
+       systemd_dounit "${S}/scripts/memcached.service"
+}
+
+pkg_postinst() {
+       elog "With this version of Memcached Gentoo now supports multiple instances."
+       elog "To enable this you should create a symlink in /etc/init.d/ for each instance"
+       elog "to /etc/init.d/memcached and create the matching conf files in /etc/conf.d/"
+       elog "Please see Gentoo bug #122246 for more info"
+}
+
+src_test() {
+       emake -j1 test
+}