dev-python/pkgconfig-1.5.1: Bump, add py38
authorPatrick McLean <patrick.mclean@sony.com>
Tue, 25 Feb 2020 01:29:09 +0000 (17:29 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 25 Feb 2020 02:05:06 +0000 (18:05 -0800)
Had to drop arm64 keyword due to pyproject2setuppy dependency. Will be
included in a to-be-filed keywording bug.

Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/pkgconfig/Manifest
dev-python/pkgconfig/pkgconfig-1.5.1.ebuild [new file with mode: 0644]

index 845f68183b69c3666f3add6ef0811f8ba80f0341..4a982411250cedc528d479f37ce63eae757770ee 100644 (file)
@@ -1,2 +1,3 @@
 DIST pkgconfig-1.2.2.tar.gz 5305 BLAKE2B 39fe5e05489e4eb8fefce66f23820d96039f5dfb82148e8ac2d691644aa2d4f1205bfa483f9fdc69837b7956834d1525d85281ba6aa0a0c079748336d47708c7 SHA512 88cfb27755297871c500f37c422da5d4ae30a14e0b9974afbe63f22c59746be0d175b65d9e3d2ed315b4d942046e7c18be062aef914199c99070a2767699848b
 DIST pkgconfig-1.4.0.tar.gz 5915 BLAKE2B 17ae11783b6642f6c8e726b42b725b7904ea282829b4527f92daa1e6ea43c3c126e6ef7e29fe5eefc89b40f3b69799087a46df6ac5695a593903dab9dc247c04 SHA512 8a270449b7b8b850aab9cc5774d1d6c6b68254f00157b66530c15697eda214948d3a71a75725067d63b906a9c3b1d789a775ac15a1094ff5ba3f227bcd666528
+DIST pkgconfig-1.5.1.tar.gz 7000 BLAKE2B 5eec60ed5af17315513f676ba37b201f4ce897089a823a9bac89d281095848504f69fdb02637eefa2872cfc6e4d1150fc18d0185288c3418500a0e201be8fc59 SHA512 2d62ad1a51620d4ccbeedf621b563c42258d69cf3aeb63f2a29399a9e03f111be1728bdb0d9d924f916839cf9a3d7625bbdd1a7b6f2471a221e764180a56fa59
diff --git a/dev-python/pkgconfig/pkgconfig-1.5.1.ebuild b/dev-python/pkgconfig/pkgconfig-1.5.1.ebuild
new file mode 100644 (file)
index 0000000..2ea65fc
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Interface Python with pkg-config"
+HOMEPAGE="https://pypi.org/project/pkgconfig/ https://github.com/matze/pkgconfig"
+SRC_URI="https://github.com/matze/pkgconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="virtual/pkgconfig"
+
+distutils_enable_tests pytest