app-admin/keepassxc: Revbumps to add QA fixes (bug #634078).
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 13 Oct 2017 09:26:45 +0000 (11:26 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 13 Oct 2017 09:27:35 +0000 (11:27 +0200)
Package-Manager: Portage-2.3.11, Repoman-2.3.3

app-admin/keepassxc/keepassxc-2.1.4-r1.ebuild [moved from app-admin/keepassxc/keepassxc-2.1.4.ebuild with 82% similarity]
app-admin/keepassxc/keepassxc-2.2.1-r1.ebuild [moved from app-admin/keepassxc/keepassxc-2.2.1.ebuild with 83% similarity]
app-admin/keepassxc/keepassxc-9999.ebuild

similarity index 82%
rename from app-admin/keepassxc/keepassxc-2.1.4.ebuild
rename to app-admin/keepassxc/keepassxc-2.1.4-r1.ebuild
index a898d01585bfbcb1a15f6c7c651b0159fc2c6e98..25db9c565d57a86576b14120700e5dfbe9edebca 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 SCM=""
 [[ "${PV}" == 9999 ]] && SCM="git-r3"
-inherit cmake-utils ${SCM}
+inherit cmake-utils gnome2-utils xdg-utils ${SCM}
 unset SCM
 
 DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
@@ -61,3 +61,15 @@ src_configure() {
        )
        cmake-utils_src_configure
 }
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+}
similarity index 83%
rename from app-admin/keepassxc/keepassxc-2.2.1.ebuild
rename to app-admin/keepassxc/keepassxc-2.2.1-r1.ebuild
index 44773623ac03ef08b8f2dbb5d126f6707f7ab4b1..15016b6c462e81db80d0f80d55d537d7fd6e9e5f 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 SCM=""
 [[ "${PV}" == 9999 ]] && SCM="git-r3"
-inherit cmake-utils ${SCM}
+inherit cmake-utils gnome2-utils xdg-utils ${SCM}
 unset SCM
 
 DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
@@ -63,3 +63,15 @@ src_configure() {
        )
        cmake-utils_src_configure
 }
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+}
index 44773623ac03ef08b8f2dbb5d126f6707f7ab4b1..15016b6c462e81db80d0f80d55d537d7fd6e9e5f 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 SCM=""
 [[ "${PV}" == 9999 ]] && SCM="git-r3"
-inherit cmake-utils ${SCM}
+inherit cmake-utils gnome2-utils xdg-utils ${SCM}
 unset SCM
 
 DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
@@ -63,3 +63,15 @@ src_configure() {
        )
        cmake-utils_src_configure
 }
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+}