Added layman-1.0.9 to the tree. Fixes bugs #148698, #159051, #151965, #149867.
authorGunnar Wrobel <wrobel@gentoo.org>
Thu, 4 Jan 2007 11:33:57 +0000 (11:33 +0000)
committerGunnar Wrobel <wrobel@gentoo.org>
Thu, 4 Jan 2007 11:33:57 +0000 (11:33 +0000)
Package-Manager: portage-2.1.1

app-portage/layman/ChangeLog
app-portage/layman/files/digest-layman-1.0.9 [new file with mode: 0644]
app-portage/layman/layman-1.0.9.ebuild [new file with mode: 0644]

index 9f8fc369338e0c689a99bd10ccde00f64505a09b..445cbc3f5a4763953fa2aebd66716d6b23fcb0ec 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-portage/layman
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.31 2006/12/29 17:26:03 cardoe Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.32 2007/01/04 11:33:57 wrobel Exp $
+
+*layman-1.0.9 (04 Jan 2007)
+
+  04 Jan 2007; <wrobel@gentoo.org> -layman-1.0.8.ebuild,
+  +layman-1.0.9.ebuild:
+  Added layman-1.0.9 to the tree. Fixes bugs #148698, #159051, #151965, #149867.
 
   29 Dec 2006; <doug@gentoo.org> layman-1.0.8.ebuild:
   Make layman check that nowebdav is not set on subversion since it needs webdav
diff --git a/app-portage/layman/files/digest-layman-1.0.9 b/app-portage/layman/files/digest-layman-1.0.9
new file mode 100644 (file)
index 0000000..cd854b0
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 75e1120ea8828e343a8c3e9f80294b01 layman-1.0.9.tar.gz 33929
+RMD160 6222296e6ade8d4e805e6bca673ec7f1f94969de layman-1.0.9.tar.gz 33929
+SHA256 bf7eea4d187c308de0f48223a9f306524aea4f34aa12be5a55bd9f1567199212 layman-1.0.9.tar.gz 33929
diff --git a/app-portage/layman/layman-1.0.9.ebuild b/app-portage/layman/layman-1.0.9.ebuild
new file mode 100644 (file)
index 0000000..5920a06
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-1.0.9.ebuild,v 1.1 2007/01/04 11:33:57 wrobel Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="A python script for retrieving gentoo overlays."
+HOMEPAGE="http://projects.gunnarwrobel.de/scripts"
+SRC_URI="http://build.pardus.de/downloads/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+S=${WORKDIR}/${PF}
+
+DEPEND="dev-util/subversion"
+
+pkg_setup() {
+       if built_with_use dev-util/subversion nowebdav; then
+               eerror "You must rebuild your subversion without the nowebdav USE flag"
+               die "You must rebuild your subversion without the nowebdav USE flag"
+       fi
+}
+
+src_install() {
+
+       distutils_src_install
+
+       dodir /etc/layman
+       cp etc/* ${D}/etc/layman/
+
+       doman doc/layman.8
+       dohtml doc/layman.8.html
+
+}
+
+src_test() {
+       cd ${S}
+       einfo "Running layman doctests..."
+       echo
+       if ! PYTHONPATH="." ${python} layman/tests/dtest.py; then
+               eerror "DocTests failed - please submit a bug report"
+               die "DocTesting failed!"
+       fi
+}
+
+pkg_postinst() {
+       einfo "You are now ready to add overlays into your system."
+       einfo
+       einfo "layman -L"
+       einfo
+       einfo "will display a list of available overlays."
+       einfo
+       ewarn "Use the -k switch to also list overlays that are"
+       ewarn "considered less secure."
+       einfo
+       elog  "Select an overlay and add it using"
+       einfo
+       elog  "layman -a overlay-name"
+       einfo
+       elog  "If this is the very first overlay you add with layman,"
+       elog  "you need to append the following statement to your"
+       elog  "/etc/make.conf file:"
+       elog
+       elog  "source /usr/portage/local/layman/make.conf"
+       elog
+       elog  "If you modify the 'storage' parameter in the layman"
+       elog  "configuration file (/etc/layman/layman.cfg) you will"
+       elog  "need to adapt the path given above to the new storage"
+       elog  "directory."
+       einfo
+       ewarn "Please add the 'source' statement to make.conf only AFTER "
+       ewarn "you added your first overlay. Otherwise portage will fail."
+       epause 5
+}