dev-ruby/webmock: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sun, 15 Sep 2019 05:45:34 +0000 (07:45 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 15 Sep 2019 05:45:55 +0000 (07:45 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/webmock/Manifest
dev-ruby/webmock/webmock-3.5.1.ebuild [deleted file]
dev-ruby/webmock/webmock-3.7.1.ebuild [deleted file]

index 3e4467c032c5c0a30b3ddb277b53bc822d8dfa32..177b32e352cc258dda7f0ba07dda8209e9c455c9 100644 (file)
@@ -1,6 +1,4 @@
 DIST webmock-2.3.2.gem 112128 BLAKE2B ef0a722374057d7c5392924f68de8520f08cb0aa038fc0b8511e00bbd9dc13f6535955f77611e414a33dbf0ed7a519e9c18caf8517d10be7438e7360c3037a1e SHA512 bb61b645b287d15690aa81db4d4c937d3456e1911d394ef1fb31e8ff3530d47b865aa039c8aaa4d4b6a72132dfcdd06be66adf1b53793384dc27ac1c9f9c01e6
-DIST webmock-3.5.1.gem 116736 BLAKE2B eb6531dd481588419932a93d091bf2c2802d98a9abe650e892e568f13a642c61ccbf395e293fb0b24b2e96f464902f8311d03a7afe84e917c4780d2da6000a78 SHA512 6096ebe84140e7385ac941c2f63951d19523b2f7e3330fb38181f19c423b4c4d47828d200d8921e02850374b048902191f96f8d693746bcdf284cf0c5eacd924
 DIST webmock-3.6.2.gem 117760 BLAKE2B 132b700323cbc4e753406ccfcc69375107c1d8546fd71bacf13db614d1818926321e2cd27dfc08670f908e0ac5946b06892138c2701fb1f27cfcf9fb6dd56c3d SHA512 1d6141be90840d01e3d7b8e925e0a981ac715fbca1219dd35edd7cf3bcea1c1da3442aaa131e3586f0827a7b06207314119c1f47e6ae64f11f154c70ba6fc5c2
-DIST webmock-3.7.1.gem 120832 BLAKE2B b661e0238904c42486f721e86d0c06a77ca9eb45d1ef3d975630344e1ad503d379518f0453a63fceb784f9aceeb10860e65c78b13ab02a3dd9d23d836948401d SHA512 ccee64bb2a63e7099639cdc55c04862a0cab9b19fe01c7957c3b2a0d90b1e93c79f6fdce23d1827554377666228344475125acf26bc5f98ad2f9be02f4644245
 DIST webmock-3.7.2.gem 121344 BLAKE2B 616ff870ddb78cdfbf37a94222679c3ce9fcebc9c84b8f92d0aaaefa92a028dde932d3fd51cb5f87f70f9698f4c19fac629aef29c2e3e440a4a1cc9334abcb60 SHA512 aa665ea771fbcd077f959abbfac69408726271700aed67f522a098c263bc237c741f4bc8271e053d77aa6df5156afbb21785621f7497f2fb169d9ae36ea306f3
 DIST webmock-3.7.3.gem 121856 BLAKE2B b271f3df74fcc181f05d0a5a148bfc6607c7f11a409122d64e6432a7e376e8f72ff83f885e4147d04abd033936dc4b9ef344ab6b3056de2300b54074b8ff0a40 SHA512 fc4b35b1cbd4aa9dd323a20c686ebb7af0dacc0a5b1a9d9ea916dbc93380b772da6cdb1b8193f60b785ba2bf97b8f3f525db174a4d7bb626197c00244ddb2b2c
diff --git a/dev-ruby/webmock/webmock-3.5.1.ebuild b/dev-ruby/webmock/webmock-3.5.1.ebuild
deleted file mode 100644 (file)
index ae5c4de..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/addressable-2.3.6 >=dev-ruby/crack-0.3.2 dev-ruby/hashdiff"
-
-ruby_add_bdepend "test? (
-       dev-ruby/minitest:5
-       dev-ruby/rspec:3
-       >=dev-ruby/test-unit-3.0.0
-       dev-ruby/rack
-       >=dev-ruby/httpclient-2.8.0
-       || ( dev-ruby/http:4 dev-ruby/http:3 ) )"
-
-all_ruby_prepare() {
-       # Remove bundler support
-       rm Gemfile || die
-       sed -i -e '/[Bb]undler/d' Rakefile || die
-       sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
-       sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
-       # There is now optional support for curb and typhoeus which we don't
-       # have in Gentoo yet. em_http_request is available in Gentoo but its
-       # version is too old. patron's latest version is not compatible.
-       sed -i -e '/\(curb\|typhoeus\|em-http\|patron\)/d' spec/spec_helper.rb || die
-       rm spec/acceptance/{typhoeus,curb,excon,em_http_request,patron}/* || die
-
-       # Avoid httpclient specs that require network access, most likely
-       # because mocking does not fully work.
-       sed -i -e '/httpclient streams response/,/^  end/ s:^:#:' \
-               -e '/are detected when manually specifying Authorization header/,/^    end/ s:^:#:' \
-               spec/acceptance/httpclient/httpclient_spec.rb
-
-       # Avoid specs that require network access
-       sed -i -e '/when request is not stubbed/,/^      end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-}
-
-each_ruby_test() {
-       ${RUBY} -S rake test NO_CONNECTION=true || die
-       ${RUBY} -S rspec-3 spec || die
-
-       einfo "Delay to allow the test server to stop"
-       sleep 10
-}
diff --git a/dev-ruby/webmock/webmock-3.7.1.ebuild b/dev-ruby/webmock/webmock-3.7.1.ebuild
deleted file mode 100644 (file)
index 377168a..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/addressable-2.3.6 >=dev-ruby/crack-0.3.2 >=dev-ruby/hashdiff-0.4.0:0"
-
-ruby_add_bdepend "test? (
-       dev-ruby/minitest:5
-       dev-ruby/rspec:3
-       >=dev-ruby/test-unit-3.0.0
-       dev-ruby/rack
-       >=dev-ruby/httpclient-2.8.0
-       || ( dev-ruby/http:4 dev-ruby/http:3 ) )"
-
-all_ruby_prepare() {
-       # Remove bundler support
-       rm Gemfile || die
-       sed -i -e '/[Bb]undler/d' Rakefile || die
-       sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
-       sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
-       # There is now optional support for curb and typhoeus which we don't
-       # have in Gentoo yet. em_http_request is available in Gentoo but its
-       # version is too old. patron's latest version is not compatible.
-       sed -i -e '/\(curb\|typhoeus\|em-http\|patron\)/d' spec/spec_helper.rb || die
-       rm spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client}/* || die
-
-       # Avoid httpclient specs that require network access, most likely
-       # because mocking does not fully work.
-       sed -i -e '/httpclient streams response/,/^  end/ s:^:#:' \
-               -e '/are detected when manually specifying Authorization header/,/^    end/ s:^:#:' \
-               spec/acceptance/httpclient/httpclient_spec.rb
-
-       # Avoid specs that require network access
-       sed -i -e '/when request is not stubbed/,/^      end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-}
-
-each_ruby_test() {
-       ${RUBY} -S rake test NO_CONNECTION=true || die
-       ${RUBY} -S rspec-3 spec || die
-
-       einfo "Delay to allow the test server to stop"
-       sleep 10
-}