dev-python/ws4py: git-2->git-r3
authorMarty E. Plummer <hanetzer@startmail.com>
Fri, 27 Apr 2018 18:55:43 +0000 (13:55 -0500)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Apr 2018 10:29:23 +0000 (12:29 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

dev-python/ws4py/ws4py-0.3.4-r1.ebuild
dev-python/ws4py/ws4py-0.3.4.ebuild
dev-python/ws4py/ws4py-0.5.1.ebuild
dev-python/ws4py/ws4py-9999.ebuild

index 6ab67dfda7d91c7aa179b6c7785cbeb5a34fa98a..ee738e5a2731740a13b63fa24e3d6c2ab4546848 100644 (file)
@@ -6,17 +6,17 @@
 # Same for www-servers/tornado and USE=client ... so why not???
 # pypy is viable but better with a cutdown set of deps
 
-EAPI="5"
+EAPI=5
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 PYTHON_REQ_USE="threads?"
 
 inherit distutils-r1
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999* ]] ; then
        EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
-       inherit git-2
+       inherit git-r3
 else
        inherit vcs-snapshot
-       SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+       SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/v${PV} -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~x86"
 fi
 
@@ -40,7 +40,7 @@ DEPEND="test? (
        )"
 
 PATCHES=(
-       "${FILESDIR}"/${P}-tests.patch
+       "${FILESDIR}"/${PN}-0.3.4-tests.patch
 )
 
 python_test() {
index a7084914ad699fd86749d7dc144ceb11b77cd212..72726e9eda13a626627a86c1e815a3aa4db8f703 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 # We could depend on dev-python/cherrypy when USE=server, but
@@ -6,17 +6,17 @@
 # Same for www-servers/tornado and USE=client ... so why not???
 # pypy is viable but better with a cutdown set of deps
 
-EAPI="5"
+EAPI=5
 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
 PYTHON_REQ_USE="threads?"
 
 inherit distutils-r1
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999* ]] ; then
        EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
-       inherit git-2
+       inherit git-r3
 else
        inherit vcs-snapshot
-       SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+       SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/v${PV} -> ${P}.tar.gz"
        KEYWORDS="amd64 arm x86"
 fi
 
index c1c647c9a5e3edfcb53295c21d5722e300d9e934..b8797e5d4151da3061d696ab74fc632657a63fef 100644 (file)
@@ -6,14 +6,14 @@
 # Same for www-servers/tornado and USE=client ... so why not???
 # pypy is viable but better with a cutdown set of deps
 
-EAPI="6"
+EAPI=6
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 PYTHON_REQ_USE="threads?"
 
 inherit distutils-r1
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
-       inherit git-3
+       inherit git-r3
 else
        inherit vcs-snapshot
        SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
index 74386cac1ba9ce3755acecbf36c666a3cc3352ba..b8797e5d4151da3061d696ab74fc632657a63fef 100644 (file)
@@ -6,7 +6,7 @@
 # Same for www-servers/tornado and USE=client ... so why not???
 # pypy is viable but better with a cutdown set of deps
 
-EAPI="6"
+EAPI=6
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 PYTHON_REQ_USE="threads?"