Portability fix for PPC64/64UL.
authorTony Vroon <chainsaw@gentoo.org>
Sat, 23 Dec 2006 00:59:01 +0000 (00:59 +0000)
committerTony Vroon <chainsaw@gentoo.org>
Sat, 23 Dec 2006 00:59:01 +0000 (00:59 +0000)
Package-Manager: portage-2.1.2_rc3-r9

media-libs/libmikmod/ChangeLog
media-libs/libmikmod/files/digest-libmikmod-3.1.11-r3 [new file with mode: 0644]
media-libs/libmikmod/files/libmikmod-3.1.11-amd64-ppc64-archdef.patch [new file with mode: 0644]
media-libs/libmikmod/libmikmod-3.1.11-r3.ebuild [new file with mode: 0644]
media-libs/libmodplug/ChangeLog
media-libs/libmodplug/files/digest-libmodplug-0.8.4-r1 [new file with mode: 0644]
media-libs/libmodplug/files/libmodplug-0.8.4-ppc64-64ul.patch [new file with mode: 0644]
media-libs/libmodplug/libmodplug-0.8.4-r1.ebuild [new file with mode: 0644]
media-libs/libmodplug/metadata.xml

index aa67279bc1a02609a75d0f73f5ed0465c69a00cf..381c178221580be91955f81db3e168e9ed4b184c 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for media-libs/libmikmod
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/ChangeLog,v 1.43 2006/10/05 07:02:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/ChangeLog,v 1.44 2006/12/23 00:59:00 chainsaw Exp $
+
+*libmikmod-3.1.11-r3 (23 Dec 2006)
+
+  23 Dec 2006; Tony Vroon <chainsaw@gentoo.org>
+  +files/libmikmod-3.1.11-amd64-ppc64-archdef.patch,
+  +libmikmod-3.1.11-r3.ebuild:
+  Portability fix for PPC64/64UL.
 
   05 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
   -libmikmod-3.1.11-r1.ebuild:
diff --git a/media-libs/libmikmod/files/digest-libmikmod-3.1.11-r3 b/media-libs/libmikmod/files/digest-libmikmod-3.1.11-r3
new file mode 100644 (file)
index 0000000..6f92215
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 5d7a4705bbc7260332e752f32e48613b libmikmod-3.1.11-esdm4.patch.bz2 2944
+RMD160 8abf8e31a5e3cb9ebee45a04b52ef04024894e25 libmikmod-3.1.11-esdm4.patch.bz2 2944
+SHA256 3dc3d413a9c617b919523866768559bee487a240670040f987825305609987da libmikmod-3.1.11-esdm4.patch.bz2 2944
+MD5 705106da305e8de191549f1e7393185c libmikmod-3.1.11.tar.gz 611590
+RMD160 79b144cce51340b4c9abe09d1110dba2333d7bfb libmikmod-3.1.11.tar.gz 611590
+SHA256 2d7598cd2a8c61c023f27c9c7c1aca8bbfd92aadbee2f98b7a6d421eae35c929 libmikmod-3.1.11.tar.gz 611590
diff --git a/media-libs/libmikmod/files/libmikmod-3.1.11-amd64-ppc64-archdef.patch b/media-libs/libmikmod/files/libmikmod-3.1.11-amd64-ppc64-archdef.patch
new file mode 100644 (file)
index 0000000..3947a55
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ru libmikmod-3.1.11-old/include/mikmod.h.in libmikmod-3.1.11/include/mikmod.h.in
+--- libmikmod-3.1.11-old/include/mikmod.h.in   2004-05-21 13:26:08.824106896 -0500
++++ libmikmod-3.1.11/include/mikmod.h.in       2004-05-21 13:26:39.024515736 -0500
+@@ -85,7 +85,7 @@
+ @DOES_NOT_HAVE_SIGNED@
+-#if defined(__arch64__) || defined(__alpha)
++#if defined(__arch64__) || defined(__alpha) || defined(__x86_64) || defined(__powerpc64__)
+ /* 64 bit architectures */
+ typedef signed char     SBYTE;      /* 1 byte, signed */
diff --git a/media-libs/libmikmod/libmikmod-3.1.11-r3.ebuild b/media-libs/libmikmod/libmikmod-3.1.11-r3.ebuild
new file mode 100644 (file)
index 0000000..71ecd04
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/libmikmod-3.1.11-r3.ebuild,v 1.1 2006/12/23 00:59:00 chainsaw Exp $
+
+WANT_AUTOMAKE="1.5"
+
+inherit flag-o-matic eutils libtool autotools
+
+DESCRIPTION="A library to play a wide range of module formats"
+HOMEPAGE="http://mikmod.raphnet.net/"
+SRC_URI="http://mikmod.raphnet.net/files/${P}.tar.gz
+       mirror://gentoo/${P}-esdm4.patch.bz2"
+
+LICENSE="|| ( LGPL-2.1 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="oss esd alsa"
+
+DEPEND=">=media-libs/audiofile-0.2.3
+       alsa? ( >=media-libs/alsa-lib-0.5.9 )
+       esd? ( >=media-sound/esound-0.2.19 )"
+
+src_unpack() {
+       unpack ${A}
+
+       epatch "${DISTDIR}"/${P}-esdm4.patch.bz2
+
+       cd "${S}"
+       epatch "${FILESDIR}"/${P}-m4.patch
+       epatch "${FILESDIR}"/${P}-amd64-ppc64-archdef.patch
+       epatch "${FILESDIR}"/${P}-respectflags.patch
+       AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_compile() {
+       econf \
+               --enable-af \
+               $(use_enable esd) \
+               $(use_enable alsa) \
+               $(use_enable oss) \
+               || die
+       emake || die
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+       dodoc AUTHORS NEWS README TODO
+       dohtml docs/*.html
+}
index be11ff2d2ebb16eb002668b3d3add48ea2f5f455..e58ce3886c226a755b552f9f6329baec581ea87f 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for media-libs/libmodplug
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmodplug/ChangeLog,v 1.27 2006/12/02 23:23:01 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmodplug/ChangeLog,v 1.28 2006/12/23 00:56:34 chainsaw Exp $
+
+*libmodplug-0.8.4-r1 (23 Dec 2006)
+
+  23 Dec 2006; Tony Vroon <chainsaw@gentoo.org>
+  +files/libmodplug-0.8.4-ppc64-64ul.patch, metadata.xml,
+  +libmodplug-0.8.4-r1.ebuild:
+  Portability fix for PPC64/64UL.
 
   02 Dec 2006; <blubb@gentoo.org> libmodplug-0.8-r1.ebuild:
   stable on amd64
diff --git a/media-libs/libmodplug/files/digest-libmodplug-0.8.4-r1 b/media-libs/libmodplug/files/digest-libmodplug-0.8.4-r1
new file mode 100644 (file)
index 0000000..590a3cc
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 091bd1168a524a4f36fc61f95209e7e4 libmodplug-0.8.4.tar.gz 510758
+RMD160 0c4c179ebc32bf88cecb162c391e91a5d36ad834 libmodplug-0.8.4.tar.gz 510758
+SHA256 84890249b3ecf12ef040b9121b6238248fc8da0fee948661d70375049e5131ee libmodplug-0.8.4.tar.gz 510758
diff --git a/media-libs/libmodplug/files/libmodplug-0.8.4-ppc64-64ul.patch b/media-libs/libmodplug/files/libmodplug-0.8.4-ppc64-64ul.patch
new file mode 100644 (file)
index 0000000..3e86c10
--- /dev/null
@@ -0,0 +1,12 @@
+diff -uNr libmodplug-0.8.4.ORIG/src/libmodplug/stdafx.h libmodplug-0.8.4/src/libmodplug/stdafx.h
+--- libmodplug-0.8.4.ORIG/src/libmodplug/stdafx.h      2006-12-23 00:40:42.000000000 +0000
++++ libmodplug-0.8.4/src/libmodplug/stdafx.h   2006-12-23 00:42:45.000000000 +0000
+@@ -21,7 +21,7 @@
+ inline void ProcessPlugins(int n) {}
+-#elif defined(__x86_64__)
++#elif defined(__x86_64__) || defined(__powerpc64__)
+ #include <stdlib.h>
+ #include <stdio.h>
diff --git a/media-libs/libmodplug/libmodplug-0.8.4-r1.ebuild b/media-libs/libmodplug/libmodplug-0.8.4-r1.ebuild
new file mode 100644 (file)
index 0000000..f5df77e
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmodplug/libmodplug-0.8.4-r1.ebuild,v 1.1 2006/12/23 00:56:34 chainsaw Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
+
+DESCRIPTION="Library for playing MOD-like music files"
+SRC_URI="mirror://sourceforge/modplug-xmms/${P}.tar.gz"
+HOMEPAGE="http://modplug-xmms.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+#-sparc: 1.0 - Bus Error on play
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh -sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-util/pkgconfig"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${PN}-0.7-amd64.patch"
+       epatch "${FILESDIR}/${PN}-0.8.4-timidity-patches.patch"
+       epatch "${FILESDIR}/${PN}-0.8.4-ppc64-64ul.patch"
+
+       sed -i -e 's:-ffast-math::' "${S}/configure.in"
+
+       eautoreconf
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+       dodoc AUTHORS ChangeLog README TODO
+}
+
+pkg_postinst() {
+       elog "Since version 0.8.4 onward, libmodplug supports MIDI playback."
+       elog "unfortunately to work correctly, this needs timidity patches,"
+       elog "but the code does not support the needed 'source' directive to"
+       elog "work with the patches currently in portage. For this reason it"
+       elog "will not work as intended yet."
+}
index a025c77c7636b6fab65649bc3d8ee8dbfcebb560..e1774e3d9ad71fcd59b25ed8c584d61740a2d118 100644 (file)
@@ -2,8 +2,4 @@
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
 <herd>sound</herd>
-<maintainer>
-  <email>chainsaw@gentoo.org</email>
-  <name>Tony Vroon</name>
-</maintainer>
 </pkgmetadata>