dev-libs/flatbuffers: revision bump installs missing flatc
authorMichael Palimaka <kensington@gentoo.org>
Fri, 2 Feb 2018 09:37:01 +0000 (20:37 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Fri, 2 Feb 2018 11:40:23 +0000 (22:40 +1100)
This resolves a regression introduced in 1.8.0.

Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-libs/flatbuffers/flatbuffers-1.8.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/flatbuffers/flatbuffers-1.8.0-r1.ebuild b/dev-libs/flatbuffers/flatbuffers-1.8.0-r1.ebuild
new file mode 100644 (file)
index 0000000..4a387f3
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Memory efficient serialization library"
+HOMEPAGE="https://google.github.io/flatbuffers/"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs test"
+
+src_configure() {
+       append-cppflags -std=c++11
+
+       local mycmakeargs=(
+               -DFLATBUFFERS_BUILD_FLATLIB=$(usex static-libs)
+               -DFLATBUFFERS_BUILD_SHAREDLIB=ON
+               -DFLATBUFFERS_BUILD_TESTS=$(usex test)
+       )
+
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       dobin "${CMAKE_BUILD_DIR}"/flatc
+}