dev-libs/bemenu: fix 9999 build
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 15 Mar 2020 19:11:03 +0000 (14:11 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 15 Mar 2020 19:12:48 +0000 (14:12 -0500)
Closes: https://bugs.gentoo.org/712398
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-libs/bemenu/bemenu-9999.ebuild
dev-libs/bemenu/files/soname-fix.patch [new file with mode: 0644]

index cc3b01f2040d06c10b4b8878cebd53d3e25d9d9a..8b4263622de982353f40617bd7f0aec14a7f3eaf 100644 (file)
@@ -3,8 +3,6 @@
 
 EAPI=7
 
-inherit cmake-utils
-
 DESCRIPTION="dmenu clone for wayland"
 HOMEPAGE="https://github.com/Cloudef/bemenu"
 if [[ ${PV} == 9999 ]]; then
@@ -36,21 +34,19 @@ DEPEND="
                x11-libs/libX11
                x11-libs/cairo[X]
                x11-libs/pango[X]
+               x11-libs/libXinerama
        )
 "
 RDEPEND="${DEPEND}"
 BDEPEND="doc? ( app-doc/doxygen )"
 
-src_configure() {
-       local mycmakeargs=(
-               -DCURSES_LIBRARY=/usr/$(get_libdir)/libncursesw.so
-               -DBEMENU_CURSES_RENDERER=$(usex ncurses ON OFF)
-               -DBEMENU_WAYLAND_RENDERER=$(usex wayland ON OFF)
-               -DBEMENU_X11_RENDERER=$(usex X ON OFF)
-       )
-       cmake-utils_src_configure
+PATCHES=( "${FILESDIR}/soname-fix.patch" )
+
+src_compile() {
+       emake clients $(usex ncurses curses) $(usex X x11) $(usex wayland wayland)
+       use doc && emake doxygen
 }
 
 src_install() {
-       cmake-utils_src_install
+       emake install PREFIX="${D}"/usr libdir=/$(get_libdir)
 }
diff --git a/dev-libs/bemenu/files/soname-fix.patch b/dev-libs/bemenu/files/soname-fix.patch
new file mode 100644 (file)
index 0000000..7fe3338
--- /dev/null
@@ -0,0 +1,26 @@
+commit 92929f9777b9c39a2829a9db1c19ef37859dc7fc
+Author: Matthew Thode <mthode@mthode.org>
+Date:   Sun Mar 15 14:00:14 2020 -0500
+
+    add soname to shared libraries
+    
+    Found in Gentoo QA
+    
+    * QA Notice: The following shared libraries lack a SONAME
+    * /usr/lib/libbemenu.so.0.4.0
+    
+    Signed-off-by: Matthew Thode <mthode@mthode.org>
+
+diff --git a/GNUmakefile b/GNUmakefile
+index c82bfd3..5b7b081 100644
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -36,7 +36,7 @@ wayland: bemenu-renderer-wayland.so
+       $(LINK.c) -c $(filter %.c,$^) $(LDLIBS) -o $@
+ $(libs): %: VERSION .git/index
+-      $(LINK.c) -shared -fPIC $(filter %.c %.a,$^) $(LDLIBS) -o $(addsuffix .$(VERSION), $@)
++      $(LINK.c) -shared -fPIC $(filter %.c %.a,$^) $(LDLIBS) -o $(addsuffix .$(VERSION), $@) -Wl,-soname
+       ln -fs $(addsuffix .$(VERSION), $@) $(addsuffix .$(firstword $(subst ., ,$(VERSION))), $@)
+       ln -fs $(addsuffix .$(VERSION), $@) $@