x11-misc/oroborus-keylaunch: EAPI bump 4 -> 6
authorHarri Nieminen <moikkis@gmail.com>
Thu, 2 Mar 2017 18:14:58 +0000 (20:14 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 4 Mar 2017 15:18:52 +0000 (16:18 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Closes: https://github.com/gentoo/gentoo/pull/4098

x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild [moved from x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild with 78% similarity]

similarity index 78%
rename from x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild
rename to x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild
index bcab32de50cae1136a22139da2f4fb2c9a31fc14..b4f28a884834538524fdaf4bc2a733ad46668f22 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=6
 
 MY_PN=${PN/oroborus-//}
 
@@ -20,13 +20,15 @@ RDEPEND="${DEPEND}"
 
 S=${WORKDIR}/${MY_PN}-${PV}
 
+DOCS=( README docs/example_rc debian/changelog )
+
 src_prepare() {
+       default
        sed -e "s: -g -O2 -Wall::" \
                -e "/^install:/s/install-docs//" \
                -i Makefile.in || die
 }
 
-src_install() {
-       emake DESTDIR="${D}" install
-       dodoc README docs/example_rc debian/changelog
+src_compile() {
+       emake VERBOSE=1
 }