app-office/libalkimia: 7.0 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 7 Feb 2018 13:22:49 +0000 (14:22 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 7 Feb 2018 14:14:34 +0000 (15:14 +0100)
Closes: https://bugs.gentoo.org/646356
Package-Manager: Portage-2.3.24, Repoman-2.3.6

app-office/libalkimia/Manifest
app-office/libalkimia/libalkimia-7.0.ebuild [new file with mode: 0644]

index c3c23fcb4f1e408e6974afd4361f100339238fd2..377485ec8f783fb43d358b56fbdf7f91033f00ec 100644 (file)
@@ -1 +1,2 @@
+DIST alkimia-7.0.tar.xz 37992 BLAKE2B 998ab4c560edf1f327369fd49e56687e35d672490fe367afbddaca5e0e8a2980213825bdeddd41e1dc37dfb825c1fc4b997e4c7c4e787ca2c819f5d0333f4688 SHA512 0d84616d6b593cba76caee4875f2cda209a4c5f3727abb9a6902faecd46dad4f4a19c099fe3c4677bf9abf540dbd5a76eacf8bb761fac3a3aee9723601064e1e
 DIST libalkimia-5.0.0.tar.xz 28400 BLAKE2B 68fa555b1e42bcadcf7aa229092e8a2d6500f4e5d03720dd259eec43daeb7f2916564500d1d2b32c0b36988a8907120404830880a7d10999c3c6b9d010903f61 SHA512 9ba205f5726f237389b9ea928ef37fc3b38161aaec5988dcc64afa3d8e53575a055b248e3c27e738db13f9e6af231f493e1374bbc50d0672729b0cdb391ce99f
diff --git a/app-office/libalkimia/libalkimia-7.0.ebuild b/app-office/libalkimia/libalkimia-7.0.ebuild
new file mode 100644 (file)
index 0000000..369d414
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+KMNAME="alkimia"
+inherit kde5
+
+DESCRIPTION="Library with common classes and functionality used by KDE finance applications"
+HOMEPAGE="https://www.linux-apps.com/content/show.php/libalkimia?content=137323"
+SRC_URI="mirror://kde/stable/${KMNAME}/${PV}/src/${KMNAME}-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/7"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+       $(add_qt_dep qtdbus)
+       dev-libs/gmp:0=[cxx]
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake-utils_use_find_package doc Doxygen)
+       )
+       kde5_src_configure
+}