rev bump for the upgrade
authorMichael Sterrett <mr_bones_@gentoo.org>
Fri, 25 Jun 2004 09:38:20 +0000 (09:38 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Fri, 25 Jun 2004 09:38:20 +0000 (09:38 +0000)
games-roguelike/tome/ChangeLog
games-roguelike/tome/Manifest
games-roguelike/tome/files/digest-tome-2.2.7-r1 [new file with mode: 0644]
games-roguelike/tome/tome-2.2.7-r1.ebuild [new file with mode: 0644]

index 6a475f307826f278b850637c6dcb5acfbd5d05a5..0a5f5279e4d3d5b7886685af2d449714ea3265ef 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for games-roguelike/tome
 # Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.12 2004/06/25 09:35:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.13 2004/06/25 09:38:20 mr_bones_ Exp $
+
+*tome-2.2.7-r1 (25 Jun 2004)
+
+  25 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> +tome-2.2.7-r1.ebuild:
+  rev bump for the upgrade
 
   25 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
   +files/2.2.7-gentoo-paths.patch, tome-2.2.7.ebuild:
index b211a28c0f5bdd3f06b4c524b21097e5376a2830..3c77b0387b05778e73380a30fc3e973f82828cc2 100644 (file)
@@ -1,10 +1,12 @@
-MD5 3e513fd216488b16a24207c1d56ddb1e ChangeLog 2848
+MD5 be1dda62c8658eeb9fac899931383fea ChangeLog 2984
 MD5 0c4f516bde25b73a560647797660c7df tome-2.2.6.ebuild 1715
 MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 bbece5987553f3a63949060172f2ba22 tome-2.2.7-r1.ebuild 1787
 MD5 3fbc4e55bce2178fee425bf9ef73f986 tome-2.2.5-r1.ebuild 1578
 MD5 fcdc294de1d0f29b52b421dad4cdcf62 tome-2.2.7.ebuild 1784
 MD5 23dd9f8f71868b8ab82d8bbbc79ad740 files/2.2.6-gentoo-paths.patch 1172
 MD5 23dd9f8f71868b8ab82d8bbbc79ad740 files/2.2.7-gentoo-paths.patch 1172
+MD5 a23d89bdd5d10666dd7030963ba64983 files/digest-tome-2.2.7-r1 66
 MD5 23dd9f8f71868b8ab82d8bbbc79ad740 files/2.2.5-gentoo-paths.patch 1172
 MD5 44a615ff66d86ba4e6b431a73ed386bc files/digest-tome-2.2.5-r1 62
 MD5 5a001b935d01d828ea36c4f5b1c75419 files/digest-tome-2.2.6 65
diff --git a/games-roguelike/tome/files/digest-tome-2.2.7-r1 b/games-roguelike/tome/files/digest-tome-2.2.7-r1
new file mode 100644 (file)
index 0000000..ff83e5d
--- /dev/null
@@ -0,0 +1 @@
+MD5 3b268d1252fa509ea498bc1d303f5a95 tome-227-src.tar.bz2 2600527
diff --git a/games-roguelike/tome/tome-2.2.7-r1.ebuild b/games-roguelike/tome/tome-2.2.7-r1.ebuild
new file mode 100644 (file)
index 0000000..6aabaae
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.2.7-r1.ebuild,v 1.1 2004/06/25 09:38:20 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_PV=${PV//./}
+DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
+HOMEPAGE="http://t-o-m-e.net/"
+SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND="virtual/glibc
+       dev-lang/lua
+       >=sys-libs/ncurses-5
+       virtual/x11"
+DEPEND="${RDEPEND}
+       >=sys-apps/sed-4"
+
+S="${WORKDIR}/tome-${MY_PV}-src"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}/src"
+       mv makefile.std makefile
+       epatch "${FILESDIR}/${PV}-gentoo-paths.patch"
+       sed -i \
+               -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c \
+               || die "sed failed"
+       find "${S}" -name .cvsignore -exec rm -f \{\} \;
+}
+
+src_compile() {
+       cd src
+       make depend || die "make depend failed"
+       emake -j1 \
+               COPTS="${CFLAGS}" \
+               BINDIR="${GAMES_BINDIR}" \
+               LIBDIR="${GAMES_DATADIR}/${PN}" \
+                       || die "emake failed"
+}
+
+src_install() {
+       cd src
+       make \
+               DESTDIR="${D}" \
+               OWNER="${GAMES_USER}" \
+               BINDIR="${GAMES_BINDIR}" \
+               LIBDIR="${GAMES_DATADIR}/${PN}" install \
+               || die "make install failed"
+       cd "${S}"
+       dodoc *.txt
+
+       dodir "${GAMES_STATEDIR}"
+       touch "${D}/${GAMES_STATEDIR}/${PN}-scores.raw"
+       prepgamesdirs
+       fperms g+w "${GAMES_STATEDIR}/${PN}-scores.raw"
+       fperms g+w "${GAMES_DATADIR}/${PN}/data"
+}
+
+pkg_postinst() {
+       games_pkg_postinst
+       echo
+       ewarn "ToME ${PV} is not save-game compatible with previous versions."
+       echo
+       einfo "If you have older save files and you wish to continue those games,"
+       einfo "you'll need to remerge the version of ToME with which you started"
+       einfo "those save-games."
+}