www-apache/mod_qos: Bump to 11.61
authorPacho Ramos <pacho@gentoo.org>
Sat, 26 Jan 2019 12:41:00 +0000 (13:41 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 26 Jan 2019 12:42:39 +0000 (13:42 +0100)
Closes: https://bugs.gentoo.org/675716
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
www-apache/mod_qos/Manifest
www-apache/mod_qos/mod_qos-11.61.ebuild [new file with mode: 0644]

index a167acd69c630b65897cb29ce1e7e4b10db9f125..43de5cbc118c417d1de91d5df0a76ec23a129fc7 100644 (file)
@@ -1 +1,2 @@
 DIST mod_qos-11.12.tar.gz 509530 BLAKE2B 84f3ff54ad8203c5507e23d12bb3aed2db7c8b128d4106ea55e4ddc4e17a3bc6910a49e58e8e98624560b0e97131f2fb1ed108d865c3a510b3350070ffc1ae58 SHA512 a9597a1b7ec38ec9ad492c79b797a807e180feb11a42cf7e206ca3cecf9c986eecc9979659a65fcc9ec0454ef8574dbdfc2c5abd862d8b3bc1065a93fbe0ccb7
+DIST mod_qos-11.61.tar.gz 1242978 BLAKE2B d784538e516abda338230ae9f2580217e3727f8aa22e5d1e881d605ade06444753c9f393a16ef8c683422bb989434b1152aa06955c3f5ba5b38e486d3cc4571b SHA512 c34a970e869238a1340a4bf32f3b21ac3e19cfb65a809989c45100aa1c3559ce0a5f5c30e6366f6d65ef04ad6fc1be73f80a9fc18b7a6a164912618cce6383a8
diff --git a/www-apache/mod_qos/mod_qos-11.61.ebuild b/www-apache/mod_qos/mod_qos-11.61.ebuild
new file mode 100644 (file)
index 0000000..b7bb23e
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools apache-module
+
+DESCRIPTION="A QOS module for the apache webserver"
+HOMEPAGE="http://mod-qos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mod-qos/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-libs/libpcre:3
+       dev-libs/openssl:0=
+       media-libs/libpng:0=
+       sys-libs/zlib:0=
+"
+DEPEND="${DEPEND}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="QOS"
+DOCFILES="${S}/doc/*.txt ${S}/README.TXT"
+
+need_apache2
+
+src_prepare() {
+       cd "${S}/tools" && eautoreconf
+}
+
+src_configure() {
+       cd "${S}/tools" && econf
+}
+
+src_compile() {
+       apache-module_src_compile
+       emake -C "${S}/tools"
+}
+
+src_install() {
+       einfo "Installing Apache module ..."
+       cd "${S}/tools"
+       apache-module_src_install
+
+       einfo "Installing module utilities ..."
+       emake -C "${S}/tools" install DESTDIR="${D}"
+
+       # installing html documentation
+       dohtml -r -x *.txt "${S}/doc/"
+}