app-portage/g-cpan: migrate to EAPI=7 & add detection of use prefix
authorSergiy Borodych <Sergiy.Borodych@gmail.com>
Sat, 4 Apr 2020 07:46:27 +0000 (10:46 +0300)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 10 Apr 2020 23:30:57 +0000 (02:30 +0300)
prefix detecting is matter for diropts with portage user-group options

Signed-off-by: Sergiy Borodych <Sergiy.Borodych@gmail.com>
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild
app-portage/g-cpan/g-cpan-9999.ebuild

index d12aa9937dd125fa0bf7f67387a39eb66a4e610e..8bf683d29b859f0f19d00b251cc905bf3c011230 100644 (file)
@@ -1,9 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit perl-module
+
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/gentoo-perl/g-cpan.git"
        inherit git-r3
@@ -41,7 +42,11 @@ DEPEND="${COMMONDEPEND}
 
 src_install() {
        perl-module_src_install
-       diropts -m0775 -o portage -g portage
+       if ! use prefix; then
+               diropts -m0775 -o portage -g portage
+       else
+               diropts -m0775
+       fi
        dodir "/var/tmp/g-cpan"
        dodir "/var/log/g-cpan"
        keepdir "/var/log/g-cpan"
index 5fad97abc0e72b3d7b325e3172605208e28f0100..fca42099a130221c20864d15df42e995879b7fa7 100644 (file)
@@ -1,9 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit perl-module
+
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/gentoo-perl/g-cpan.git"
        inherit git-r3
@@ -43,7 +44,11 @@ DEPEND="${COMMONDEPEND}
 
 src_install() {
        perl-module_src_install
-       diropts -m0775 -o portage -g portage
+       if ! use prefix; then
+               diropts -m0775 -o portage -g portage
+       else
+               diropts -m0775
+       fi
        dodir "/var/tmp/g-cpan"
        dodir "/var/log/g-cpan"
        keepdir "/var/log/g-cpan"