dev-util/boost-build: run hprefixify on engine/Jambase
authorMichael Haubenwallner <haubi@gentoo.org>
Tue, 18 Jun 2019 12:11:23 +0000 (14:11 +0200)
committerMichael Haubenwallner <haubi@gentoo.org>
Wed, 19 Jun 2019 07:32:15 +0000 (09:32 +0200)
engine/Jambase defines default locations for boost-build, which should
stick to the EPREFIX where installed to, not the host system.
The breakage is in prefix-stack, where the boost ebuild does add the
stacked EPREFIX only as --boost-build flag, but not BROOT.  Although
this is questionable, we really should use our own prefix as fallback.

Package-Manager: Portage-2.3.66, Repoman-2.3.11
Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
dev-util/boost-build/boost-build-1.65.0.ebuild
dev-util/boost-build/boost-build-1.70.0.ebuild

index e7011fc99ca3aa6f258f992a6c46d275dac8a252..4b42b41f17cec5d2d08edd5fc638fb0c29100ab2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
 RESTRICT="test"
 
 PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic python-single-r1 toolchain-funcs versionator
+inherit eutils flag-o-matic prefix python-single-r1 toolchain-funcs versionator
 
 MY_PV="$(replace_all_version_separators _)"
 
@@ -81,6 +81,7 @@ src_prepare() {
 }
 
 src_configure() {
+       hprefixify engine/Jambase
        if use python; then
                # replace versions by user-selected one (TODO: fix this when slot-op
                # deps are available to always match the best version available)
index 98eb1a3631a76ce2ee17a6d0d1d0033d419fc18c..954e06df945399038d703b5814e3dbd2da5b5898 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python2_7 )
-inherit flag-o-matic python-single-r1 toolchain-funcs
+inherit flag-o-matic prefix python-single-r1 toolchain-funcs
 
 MY_PV="$(ver_rs 1- _)"
 
@@ -83,6 +83,7 @@ src_prepare() {
 }
 
 src_configure() {
+       hprefixify engine/Jambase
        if use python; then
                # replace versions by user-selected one (TODO: fix this when slot-op
                # deps are available to always match the best version available)