app-arch/plzip: Bump to 1.8
authorMichał Górny <mgorny@gentoo.org>
Fri, 4 Oct 2019 15:48:16 +0000 (17:48 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 4 Oct 2019 16:08:46 +0000 (18:08 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-arch/plzip/Manifest
app-arch/plzip/plzip-1.8.ebuild [new file with mode: 0644]

index 1e2755613e7f6dd4727bc0e45bd4363fe4dd5fcd..6b472e351758c87524a73132007478c8e248e906 100644 (file)
@@ -1 +1,2 @@
 DIST plzip-1.6.tar.gz 66214 BLAKE2B 8f3865b8170c456cd37ac550b68e0846316f4c7329dda4470b3298d139ca392d000a357a1ec52c0f7c2303e6612ea4a1204e93c2fa487e70f387d9cffe96c21b SHA512 14f794e290eb58bcdf1fc5699c08c36f57473e36eeb3920dff519741c4265883f8ee348095a9315562812574c3f5ece7bd7ef4a11fbd955fe2ee54e361900f77
+DIST plzip-1.8.tar.gz 72365 BLAKE2B 66b8881b6c70932c66e40edab22235103d671a870c980c0b0b08754e94fbc1b2d0f2eeb26deac4f27fbc89d69c3b588bd51cb973b7b59cbb2d0f6ab4cc9a115d SHA512 e8e822f8ae77e06178538b62075fa1c5d9cbc76c78bee7ad595a4637cd4077f53fd9e3fe61ca3fbddaa8b950e739d97527dc8fbecae04de1ac3ef83d0d5f13b4
diff --git a/app-arch/plzip/plzip-1.8.ebuild b/app-arch/plzip/plzip-1.8.ebuild
new file mode 100644 (file)
index 0000000..f9fedd5
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Parallel lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/plzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/lzlib:0="
+DEPEND=${RDEPEND}
+
+src_configure() {
+       local myconf=(
+               --prefix="${EPREFIX}"/usr
+               CXX="$(tc-getCXX)"
+               CPPFLAGS="${CPPFLAGS}"
+               CXXFLAGS="${CXXFLAGS}"
+               LDFLAGS="${LDFLAGS}"
+       )
+
+       # not autotools-based
+       ./configure "${myconf[@]}" || die
+}